Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дан многочисленный массив размера N (N меньше или равно 1000) преобразовать его след. образом: вместо отрицательных чисел поставить нули

5-9 класс

KrytouLemyrchik 25 янв. 2014 г., 12:44:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
янусик1233435
25 янв. 2014 г., 14:31:47 (10 лет назад)

Вот вариант с ручным вводом:

var  i,N:integer; 
a: array[1..1000] of integer;
BEGIN
write('Введите N');
readln(N);for i:=1 to N do read(a[i]);
write('Исходный массив:');
for i:=1 to N do 
   begin  write(a[i],' '); 
   if a[i]<0 then a[i]:=0 
   end;
writeln;
write('Преобразованный массив:');
for i:=1 to N do write(a[i],' ')
END.

Ответить

Другие вопросы из категории

Человек делает покупки в магазине. Определите сколько денег у него останется после покупки перчаток,стоимостью а рублей, портфеля,стоимостью b рублей и

галстука,стоимостью d рублей.

den-количество денег у человека; ost-остаток.
И вот эта херняяя:
Program Z1
var
a,b,c,d,den,ost: integer;
begin
А что дальше? Напиши решения задачи,пожалуйста)


Читайте также

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

1. Дан двухмерный массив A(n,m).

Найти произведение отрицательных четных элементов второго столбца массива.

2. Дан двухмерный массив m*n.
Получите одномерный массив b, элементы которого равны min элементам по строкам.

Выберите правильные ответы

1. Закончите предложение: «Алгоритмом называется …»
а) нумерованный список б) маркированный список
в) система команд исполнителя
г) конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату
2. Что можно считать алгоритмом?
а) правила техники безопасности б) список класса
в) кулинарный рецепт г) перечень обязанностей дежурного по классу
3. Закончите предложение: «Блок-схема – форма записи алгоритмов, при которой для обозначения различных шагов алгоритма используются ….»
а) рисунки б) списки в) геометрические фигуры г) формулы
4. Закончите предложение: «Геометрическая фигура параллелограмм
используется в блок-схемах для обозначения ….
а) начала и конца алгоритма б) ввода или вывода данных
в) принятия решения г) выполнения действия
5. У какого из известных Вам исполнителей следующая СКИ: вверх, вниз, вправо, влево, закрасить?
а) РОБОТ б) Чертежник в) Вычислитель г) ГРИС
6. В следующем списке 12 2,3 0 5 -5 98,0 целых величин:
а) 2 б) 3 в) 4 г) 5
7. Каждая команда алгоритма должна определять однозначное действие исполнителя. Это свойство алгоритма называется…
а ) формальность б) точность в) понятность г) массовость
8. Укажите формальных исполнителей:
а) симфонический оркестр исполняет музыку Ф. Шопена
б) ученик 9 класса решает задачу по алгебре
в) фармацевт готовит лекарство по рецепту
г) автомат на конвейере наполняет бутылки лимонадом
9. Для многократного выполнения одинаковых действий в алгоритме нужно использовать
а) ветвление б) цикл в) линейные команды
10. После выполнения фрагмента алгоритма вида:
S:=0
i:=1
пока i<4
нц
i:=i+1
S:=S+1
кц
значение переменной s равно…. а) 0 б) 3 в) 5 г) 9
11. Переменная х получила значение, равное -6. Какое значение получит переменная у после выполнения ветвления:
если а меньше или равно 3
то у:=а*а
иначе у:= 2а-3
все
а) -6 б) 6 в) 36 г) -15

Написать программу

4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов?
Подсказка:
Начальное значение переменной цикла – 2. Шаг изменения – 2 (перебираем четные числа).
Считаем сумму квадратов до тех пор пока она меньше или равна S.
Вывод на экран :
Результат:
s =
Тест 1:
Исходные данные:
s = 24
Результат:
s =56
Тест 2:
Исходные данные:
s = 85
Результат:
s =120



Вы находитесь на странице вопроса "дан многочисленный массив размера N (N меньше или равно 1000) преобразовать его след. образом: вместо отрицательных чисел поставить нули", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.