Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

в массиве действительных чисел с от 1 до 11 посчитать сумму отрицательных элементов, произведение положительных и вывести на экран номера нулевых элемен

5-9 класс

тов.
ПОМОГИТЕ ПОЖАЛУЙСТА!!!с помощью паскаля, а числа задавать можно любым способом.

Yulia02072000 21 янв. 2015 г., 20:02:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yass
21 янв. 2015 г., 21:27:58 (9 лет назад)

var a:array[1..11] of real;
sum,proiz:real;
i:integer;
begin
for i:=1 to 11 do read(s[i]);
for i:=1 to 11 
   begin
   if a[i]<0 then sum:=sum+a[i];
   if a[i]>0 then proiz:=proiz*a[i];
   if a[i]=0 then writeln(a[i]);
   end;
writeln(sum);
writeln(proiz);
end.
должно пойти


Ответить

Читайте также

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.

НА QBASIC!!!!!!!!!! 1)Для массива А. Найти количество положительных, сумму нечетных и произведение чисел, кратных В. Результаты расчетаа и

массив вывести на экран.

2)Для массива А опредилить сумму квадратов отрицательных элементов, произведение положительных элементов, нулевые-заменить числом 12. Результаты расчета и массив вывести на экран.

3)Известны данные о количестве осадков, выпавших за каждый день января. Найти общее число осадков, выпавших по нечетным числам месяца.

4)Известна стоимость каждого из 15 видов товаров. Напечатать номера тех видов товаров, которые имеют стоимость всех видов товаров.

5)Дан массив А, отсортировать его по возрастанию. Отсортированный массив вывести на экран.

6)Дан массив А, Отсортировать его по убыванию. Отсортированный массив вывести на экран.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?



Вы находитесь на странице вопроса "в массиве действительных чисел с от 1 до 11 посчитать сумму отрицательных элементов, произведение положительных и вывести на экран номера нулевых элемен", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.