Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Паскаль.для х составить программу вычисления 1+х/1!+х2/3!+х3/5!+...+xn/(2n-1)!

5-9 класс

Kapcho 14 янв. 2015 г., 16:53:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Floverokkk
14 янв. 2015 г., 18:28:22 (9 лет назад)

uses crt;
var a,n,i:integer;s,x:real;
function fact (n:integer):integer;
var result : integer;
i:integer;
begin
result:=1;
for i:=1 to n do
result:=result*i;
fact:=result;
end;
begin
s:=0;
readln(n,x);
for i:=1 to n do
s:= s+(1+x/fact(2*i-1));
writeln(s);
end.

Ответить

Другие вопросы из категории

программист написал программу на языке машинных команд, которая последовательнно размещается в памяти начиная с нулевого адреса. Каждая команда

занимает 4 байта памяти. 16ричный адрес последней команды в программе равен 28.сколько команд содержит эта программа?

1. Язык программирования Pascal создал:

a. Н. Вирт

b. Б. Паскаль

c. М. Фортран

d. Правильных ответов нет

2. Линейная структура построения программы подразумевает

a. Неоднократное повторение отдельных частей программы

b. Последовательное выполнение всех элементов программы

c. Выполнение лишь нескольких, удовлетворяющих заданному условию частей программы

d. Верного ответа нет

3. Оператор присваивания имеет вид:

a. =

b. :=

c. =:

d. Верного ответа нет

4. Команда CLRSCR служит для

a. ожидания нажатия клавиши

b. ввода данных с экрана

c. очистки экрана

d. верного ответа нет

5. раздел VAR служит

a. Для описания используемых переменных

b. Для описания величин

c. Для описания выражений

d. Верного ответа нет

6. Переменные – это:

a. величины, которые могут менять свое значение в процессе выполнения программы

b. величины, которые не могут менять своего значения в процессе выполнения программы

c. обозначают строки программы, на которые передается управление во время выполнение программы

d. Верного ответа нет

7. Правильная строковая запись выражения

a. x-х***3/abs x + sin (x)

b. x-x*x*x/abs (x) +sin (x)

c. x-(x*x*x)/abs (x) +sin (x)

d. Верного ответа нет

8. целочисленное деление можно выразить следующей функцией:

a. A mod B

b. A div B

c. Abs (A)*B

d. Верного ответа нет

9. математическое выражение х2-7х+6 можно записать:

10. выражение на паскале

(abs (x)-abs(y))/(1 + abs (1/s)) можно записать:

11. раздел операторов начинается служебным словом:

a. VAR

b. INTEGER

c. BEGIN

d. Верного ответа нет

12. ввод данных с клавиатуры осуществляется с помощью оператора:

a. WRITE, WRITELN

b. READ, READLN

c. PROGRAM

d. Верного ответа нет

13. вывод данных на экран осуществляется с помощью оператора:

a. WRITE, WRITELN

b. READ, READLN

c. PROGRAM

d. Верного ответа нет

14. чему будет равно значение переменной М в результате выполнения серии операторов
N:=5;

Y:=2;

M:=N/5+3*Y*N

15. тип переменных REAL это:

a. целочисленный тип

b. логический тип

c. натуральный тип

d. верного ответа нет



Читайте также

мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(

N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!

1. Составьте блок-схему алгоритма и программу вычисления площади треугольника по трем сторонам. 2. Составьте программу вычисления объема, площади полной

поверхности, суммы ребер прямоугольного параллелепипеда. 3. Составьте программу вычисления диагоналей ромба по стороне и углу.

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ.

Агент 007 узнал, что в секретном сейфе трёхзначный код, в котором все три цифры разные.При этом средняя цифра равна разности крайних цифр. Составить программу, которая напечатает для него все такие числа.



Вы находитесь на странице вопроса "Паскаль.для х составить программу вычисления 1+х/1!+х2/3!+х3/5!+...+xn/(2n-1)!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.