Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите найти ошибку!!! 1. "Дано число, определить количество четных цифр." Program task3; var a, ost, k: integer;

5-9 класс

begin
write ('Ввести число a ->'); read (a);
k:=0;
while a<>0 do begin
ost:= a mod 10;
if ost div 2 = 0 then k:=k+1;
end;
writeln (k);
end.

2. "Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали в дневник температуру. Найти среднюю температуру для дней с температурой выше 0 градусов. Определите количество дней. Программа получает на выход количество дней, в течении которых проводится наблюдение."

Program task4;

var a, s, t, y, k: integer; n: real;
begin
write ('Введи количество дней ->');
read (a);
k:=1;
s:=0;
t:=y;
repeat
write ('Введи температуру в ',k,'-ый день');
read (y);
if a>31 then write ('Количество дней в месяце меньше 31');
if t>0 then k:=k+1;
if t>0 then s:=s+t;
if t=y then write ('k=',k); write ('s=',s);
until t=y;
if t=y then n:=s/k;
writeln ('n=',n);
end.

Nikitakorobkin 14 сент. 2016 г., 15:19:13 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kristinahvatov
14 сент. 2016 г., 17:30:48 (7 лет назад)

1) Program task3;
var a, ost, k: integer;
begin
write (Ввести число a ->'); read (a);
k:=0;
while a<>0 do begin
ost:= a mod 10;
if ost mod 2 = 0 then k:=k+1;
a := a div 10
end;
writeln (k); 
end. 

 

2)  Эту не знала как исправить, поэтому в основном просто переписала :)

Program task4;
var a, s, t, i, k: integer; n: real;
begin
write ('Введи кол-во дней -> ');
readln (a);
k:=0;
s:=0;
For i := 1 to a do
begin
write ('введи температуру в  ',i,-ый день');
readln(t);
if t>0 then
begin
k:=k+1;
s:=s+t;
end;
end;
writeln('Кол-во дней, в течение которых проводилось наблюдение ', a);
writeln('Кол-во дней с  t>0 = ', k);
n:=s/k;
writeln (Средняя температура в дни с  t>0 ',n)
end.

 

Ответить

Другие вопросы из категории

Для групповых операций с файлами используются маски имён файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов

символов, в которых также могут встречаться следующие символы. Символ «?» (вопросительный знак) означает ровно один произвольный символ. Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность. В каталоге находится 6 файлов: asc.wma casting.wmv last.wma pasta.wmvx pasta.wri vast.wma Определите, по какой из перечисленных масок из этих 6 файлов будет отобрана указанная группа файлов: casting.wmv last.wma pasta.wmvx vast.wma 1) ?as*.wm? 2) *as?.wm* 3) ?as*.wm* 4) ?as*.w*

Примерами фактов являются:

а) статьи в толковых словарях и энциклопедиях;
б) описание способа обучения малышей грамоте;
в) описание последовательности действий при включении компьютера;
г) алгоритм решения уравнения;
д) описание, как приготовить борщ.
Примерами правил являются:
а) описание строения атома;
б) описание строения Солнечной системы;
в) таблица умножения;
г) знание об устройстве компьютера;
д) описание способа лечения болезни человека.

Система взаимосвязанных технических устройств, выполняющих ввод, хранение, обработку и вывод информации называется: 1. программное

обеспечение;

2. компьютерное обеспечение;

3. аппаратное обеспечение.

4. системное обеспечение;

Читайте также

Очень нужна помощь. Помогите найти ошибки - Паскаль.

Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами.

Не совсем то выводит, и модуль может как-то через abs надо.

program proizvedenie;
var q,z,w,i,n,i1,i2:integer;
a:array[1..1000] of real;
amin,amax,pr:real;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
amin:=a[1];
for i:=1 to n do
begin
if a[i]<amin then
begin
amin:=a[i];
i1:=i;
end;
end;
amax:=a[1];
for i:=1 to n do
begin
if a[i] > amax then
amax:=a[i];
i2:=i;
end;
if i2>i1 then begin
q:=i1;
w:=i2;
end
else begin
q:=i2;
w:=i1;
end;
if (w-q)>1 then begin
pr:=1;
for z:=q to w do
pr:=pr*a[z];
end
else write (0);
close (input);
close (output);
end.

Pascal ABC. Вводим четырёхзначное число, определить количество чётных цифр и вывести его на экран.

Пример:
Вход 1212
На выходе 2

Я сделал:
program Test;
uses Crt;
var A,B,C,D,E: integer;
begintextbackground(8);
clrscr;
textcolor(15);
write('Введите 4-х значное число: ');
textcolor(13);
read(A);
C:=A div 1000;
B:=A div 100;
B:=A mod 10;
D:=A mod 100;
D:=A div 10;
E:=A mod 10;
E:=A mod 10;
А как дальше не знаю =(

Помогите нужно написать программу.Дано число определить четное или нечетное. Пример: дано: y=a/b решение: Program RR;

Var

a,b,y:real;

begin

Read (a,b );

if b=0 then writekn ('решения нет')

else writeln (a/b);

end,

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)



Вы находитесь на странице вопроса "помогите найти ошибку!!! 1. "Дано число, определить количество четных цифр." Program task3; var a, ost, k: integer;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.