Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Хотя бы 1.

5-9 класс

Через массивы.
9 класс.


1. Заменить в массиве все максимальные элементы нулям.
Как должно получиться:

2. В массиве 1 элемент наибольший, 1 наименьший, поменяйте их местами.

3. В целочисленном массиве найти среднее арифметические черных чисел.

Anfisulya 14 сент. 2014 г., 6:51:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aioooka
14 сент. 2014 г., 9:41:29 (9 лет назад)

Задача 3.

var
  a: array [1..100] of integer;
  n,i,c,s: integer;
begin
  readln(n);
  for i:=1 to n do begin
    a[i]:= random(100);
    if a[i] mod 2=0 then begin
      inc(c);
      s:= s+a[i];
    end
  end;
  writeln(s/c);
end.

Ответить

Другие вопросы из категории

Кто

такой Эйлер, в честь кого названа графическая схема, обозначающая отношения
между множествами?

Помогите решить!

Составить программу вычисления значений функции F(x) на отрезке [a,b] с шагом h. Результат первое значение аргумента второе- соответствующая значению функция.
записать в паскале (не через массив)
Задание 1. номер 9

Читайте также

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.

Когда мы переписываемся, мы часто

используем цифры в нашем тексте. Вам дано одно предложение на английском языке.
Нужно найти все цифры, которые встречаются в этом предложений хотя бы один раз.

Запишите команду присваивания, в результате выполнения которой логическая переменная t получает значение TRUE, если выполняется указанное условия, и

значение FALSE в противном случае:
a) x -- положительное число
б) хотя бы одно из чисел x,y,z равно нулю
в) числа x,y,z равны между собой
г) уравнение ax^2+bx+c=0 имеет ровно один корень

Решите пожалуйста все, очень нужно.

Если ответите хотя бы на 70%, поставлю Ваш ответ, как лучший <з



Вы находитесь на странице вопроса "Хотя бы 1.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.