Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать программу, которая проверяет – имеется ли в записи натурального числа ноль.

5-9 класс

Язык программирования паскаль.

Nzhur 18 июля 2016 г., 9:24:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jessicaone1
18 июля 2016 г., 10:05:20 (7 лет назад)

program red;
var a,b,c:integer;
begin
b:=0;
readln(a);
if a<10 then
begin
if a*5=0 then b:=1;
end;
if (a>=10) and (a<100) then
begin
if ((a div 10)*5=0) then b:=1;
if ((a mod 10)*5=0) then b:=1;
end;
if (a>=100) and (a<1000) then
begin
if ((a div 100)*5=0) then b:=1;
if (((a div 10) mod 10)*5=0)then b:=1;
if ((a mod 10)*5=0)then b:=1;
end;
if b=1 then writeln('yes') else writeln('no');
end.

Ответить

Читайте также

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Написать программу, которая проверяет, является ли введённая с

клавиатуры строка шестнадцатеричным числом. В Паскале.



Вы находитесь на странице вопроса "Написать программу, которая проверяет – имеется ли в записи натурального числа ноль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.