Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Pascal ABC Операторы case of ; if then else ; for to do;

10-11 класс

Помогите написать программы..........................................................................................
................................................. которые находятся в файле

Vikabc2013 14 февр. 2014 г., 14:29:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katerinacemenova
14 февр. 2014 г., 16:30:41 (10 лет назад)

Задача 1 
Var i,n,a,sum:integer;
Begin 
  Write('Введите n: '); readln(n);   
    for i:=1 to n do   
  if (i mod 2 = 0) then begin   
 a:=a+1;   
 sum:=sum+i;                           
                 end;   
Writeln('Кол-во четных чисел: ',a,' их сумма = ',sum);
End.

Задача 2 
Var i:integer;
Begin   
   for i:=100 to 999 do   
     if (i mod 2 = 0) then write(' ',i);
End.

Задача 3 
Var i,k,i1,i2,i3:integer;
Begin 
Write('Введите k: '); readln(k);   
   for i:=100 to 999 do begin   
i1:=i div 100;   
i2:=i mod 100; i2:=i2 div 10;   
i3:=i mod 10;   
      if (i1+i2+i3 = k) then write(' ',i);     
              end;
End.

+ 0 -
RedPandaOlolo
14 февр. 2014 г., 19:20:09 (10 лет назад)

А ты знаешь иной способ записать в переменную каждую цифру числа? :)

+ 0 -
Veronika082014
14 февр. 2014 г., 21:35:39 (10 лет назад)

mod это остаток от деления, а div это целая часть от деления

+ 0 -
DianaKh
14 февр. 2014 г., 22:20:50 (10 лет назад)

Да, с этим я разберусь, в любом случае спасибо

+ 0 -
Kyzvlad2001
15 февр. 2014 г., 0:36:07 (10 лет назад)

например 123 mod 10 = 3 т.к. 123/10 = 12,3 остаток 3, если использовать div то будет число 12

+ 0 -
Obabkin
15 февр. 2014 г., 3:05:32 (10 лет назад)

mod это дробная часть точнее

Ответить

Другие вопросы из категории

Для построения сети с топологией "звезда" обычно применяется...

1) ...коаксиальный кабель, коннекторы и терминаторы

2) ...кабель "витая пара" и концентратор (Hub)

3) ...оборудование стандарта Token Ring

4) все ответы верны

Читайте также

Pascal ABC

Оператор case of и if then else:

Задача 1
Вводятся 3 числа. Можно
ли построить треугольник с такими сторонами? Если построить треугольник можно,
то определить, является ли он
равносторонним, равнобедренным или прямоугольным?

Pascal ABC

Операторы case of и if the else
Помогите написать программу...

Найти алгоритм решения задачи и реализовать его с помощью оператора(операторов) if-then-else. В Атлантическом океане терпит бедствие пассажирский теплоход

”Посудина”. Все пассажиры будут спасены, если на помощь успеют два судна. Судно продержится на плаву t часов. Скорость судов-спасателей 40 узлов. Составить программу, определяющую спасутся ли пассажиры. Известны расстояния от трех судов-спасателей до тонущего судна.

Дана программа, переписать ее с помощью оператора case. var a,b,x:real; begin readln(a,b); if a=0 then if b=0 then

write('x-любое число')

else

write('нет решений')

else

write('x=',-b/a);

end.



Вы находитесь на странице вопроса "Pascal ABC Операторы case of ; if then else ; for to do;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.