Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти алгоритм решения задачи и реализовать его с помощью оператора(операторов) if-then-else. В Атлантическом океане терпит бедствие пассажирский теплоход

10-11 класс

”Посудина”. Все пассажиры будут спасены, если на помощь успеют два судна. Судно продержится на плаву t часов. Скорость судов-спасателей 40 узлов. Составить программу, определяющую спасутся ли пассажиры. Известны расстояния от трех судов-спасателей до тонущего судна.

Kumpantatyana 05 нояб. 2013 г., 5:49:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Caitlin1711
05 нояб. 2013 г., 8:03:00 (10 лет назад)

const
  v=40;
var
  t,r1,r2,r3:real;
  n:integer;
begin
write('Сколько часов продержатся пассажиры? ');
readln(t);
write('Введите расстояния до трех спасателей (в узлах): ');
readln(r1,r2,r3);
if r1/v<t then n:=1;
if r2/v<t then n:=n+1;
if r3/v<t then n:=n+1; 
If n>1 then writeln('Спасутся все')
  else
    if n>0 then writeln('Спасется половина пассажиров')
      else writeln('Никто не спасется')
end.    

Ответить

Другие вопросы из категории

Отсортировать массив из N целых

чисел в неубывающем порядке с помощью сортировки прямыми вставками На языке С++

1)В

программе описан одномерный целочисленный массив с индексами от 0 до 10. В
приведенном ниже фрагменте программы массив сначала заполняется, а потом
изменяется:

Читайте также

Составить алгоритм для решения задачи и определить его вид: 1)Дан массив А(9). Поменять местами элементы относительно А(5). 2)Дан массив из 6 элементов. Пе

рвый равен 3. каждый следующий элемент получается из предыдущего умноженного его на 2. Найти все элементы массива и вывести массив на экран.

Задание: составить программу решения задачи.

Указания к выполнению: самостоятельно выполнить все этапы решения
задачи. Ввод и вывод матрицы оформить в виде процедур. При
необходимости выделить в задаче вспомогательные алгоритмы и оформить
их в виде подпрограмм.паскаль

Дана матрица, определить количество «особых» элементов. Элемент
считается «особым», если он больше суммы остальных элементов строки.
.

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}



Вы находитесь на странице вопроса "Найти алгоритм решения задачи и реализовать его с помощью оператора(операторов) if-then-else. В Атлантическом океане терпит бедствие пассажирский теплоход", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.