Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПОМОГИТЕ! Нужно написать программу в паскале. 1. Поменяйте местами первый элемен массива А(8) с наибольшим элементом, а

10-11 класс

последний - с наименьшим элементом массива. Случайные числа в [10;99]

2. Посчитайте сумму чётных элементов массива А(8). Случайные числа в [1;9]

3. Найдите номер нулевого элемента данного одномерного массива А(10). Случайные числа в [-10;10]

билянка 27 марта 2014 г., 7:02:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valeriyabilich
27 марта 2014 г., 8:36:11 (10 лет назад)

program n1;

  uses crt;

  var

   a:array[1..10000] of integer;

    i,min,max:integer;

  begin

   clrscr;

   for i:=1 to 8 do

     begin

      randomize;

      a[i]:=random(99-10+1)+10;

      write(a[i],' '); {выводим изначальный массив}

     end;

   min:=a[1]; max:=a[8];

   for i:=1 to 8 do

     begin

      if min>a[i] then min:=a[i];

      if max<a[i] then max:=a[i];

     end;

  for i:=1 to 8 do

    begin

     if (a[i]=min) and (a[i]<a[1]) then

       begin

         a[i]:=a[1]; a[1]:=min;

       end;

    if (a[i]=max) and (a[i]>a[8]) then

       begin

        a[i]:=a[8]; a[8]:=max;

       end;

    end;

  writeln;

  for i:=1 to 8 do

  write (a[i],' '); {выводим измененный массив}

  end.

 

program n2;

  uses crt;

  var

   a:array[1..10000] of integer;

    i,n:integer;

  begin

   clrscr;

   n:=0;

   for i:=1 to 8 do

     begin

      randomize;

      a[i]:=random(9-1+1)+1;

      write(a[i],' '); {выводим массив}

      if a[i] mod 2=0 then n:=n+a[i];

     end;

     writeln;

    writeln (n);

   end.

 

program n3;

  uses crt;

  var

   a:array[1..10000] of integer;

    i,n:integer;

  begin

   clrscr;

   n:=0;

   for i:=1 to 10 do

     begin

      randomize;

      a[i]:=random(20)-10;

      write(a[i],' '); {выводи массив}

      end;

   for i:=1 to  10 do

     begin

     if a[i]=0 then n:=n+1;

     if (a[i]=0) and (n=1) then begin writeln; writeln(i,' – первый нулевой элемент ' );  end;

     if (i=10) and (n=0)then begin writeln; writeln (нулевого элемента нет);   end;

     end;

   end.

Ответить

Другие вопросы из категории

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Pascal ABC Операторы case of ; if then else ; for to do;

Помогите написать программы..........................................................................................
................................................. которые находятся в файле

Для построения сети с топологией "звезда" обычно применяется...

1) ...коаксиальный кабель, коннекторы и терминаторы

2) ...кабель "витая пара" и концентратор (Hub)

3) ...оборудование стандарта Token Ring

4) все ответы верны

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.


Известны баллы, полученные студентами за контрольную работу. Вычислить максимальный балл.

Нужно написать программу а паскале, помогите пожалуйста)



Вы находитесь на странице вопроса "ПОМОГИТЕ! Нужно написать программу в паскале. 1. Поменяйте местами первый элемен массива А(8) с наибольшим элементом, а", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.