Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана вещественная квадратная матрица А, размерностью n*n. Найти сумму элементов матрицы, расположенных под главной диагональю

10-11 класс

Mashalovowa 18 дек. 2014 г., 1:28:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ReginaLass
18 дек. 2014 г., 2:31:55 (9 лет назад)

program gt;
var n,i,j:integer;
a:array[1..100,1..100]of real;
s:real;
begin
readln(n);
for i:=1 to n do
for j:=1 to n do
begin
read(a[i,j]);
if(i=j)then s:=s+a[i,j];
end;
writeln(s);
end.

+ 0 -
Zeimus
18 дек. 2014 г., 5:04:50 (9 лет назад)

забыл откуда куда было главной диогональю?

Ответить

Другие вопросы из категории

ВОПРОС ЖИЗНИ И СМЕРТИ

Автоматизированная система управления кадрами предприятия хранит личные дела работников в следующем формате: каждое личное дело
содержит 12 страниц, по 36 строк на каждой странице, по 64 символа в каждой строке, каждый символ кодируется одним байтом. Определите количество личных дел, хранимых в автоматизированной системе, если известно, что все данные занимают в памяти компьютера 13,5 мегабайта.

Друзья! Помогите пожалуйста!!! Нужно организовать двумерный массив с количеством элементов 32,заполнить его случайными числами на интервале [10;100]

(концы интервала входят тоже) и вывести на экран монитора в матричном виде! ДЕЛАЕТСЯ ВСЕ НА GWBASIC!!!

ПОМОГИТЕ СРОЧНО!!

На схеме указаны дороги между четырьмя населёнными пунктами и отмечены длины этих дорог.Длина одной дороги неизвестна. Зато известно,что самый короткий путь между двумя наиболее удалёнными друг от друга населёнными пунктами составляет 70 км.Найдите длину неизвестной дороги,ответ запишите целым числом

Читайте также

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Дана вещественная квадратная матрица А порядка n. Найти среднее

арифметическое среди положительных элементов матрицы, находящихся на
главной и побочной диагоналях. Выдать сообщение, если таких элементов нет.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "Дана вещественная квадратная матрица А, размерностью n*n. Найти сумму элементов матрицы, расположенных под главной диагональю", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.