Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить программу нахождения суммы всех нечетных отрицательных элементов массива,образованного случайными числами в диапазоне от -30 до 30(на языке

10-11 класс

Паскаль)

Irishechka100 03 сент. 2013 г., 14:02:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yaanelya
03 сент. 2013 г., 15:41:33 (10 лет назад)

Const N = 5;
Var a:array [1..N] of integer; i,S:integer;
Begin
randomize; S:=0;
for i:=1 to N do begin
a[i]:=random(61)-30;
if (a[i]<0) and (a[i] mod 2 <>0) then S:=S+a[i]; end;
writeln(S);
readln;
end.

Ответить

Другие вопросы из категории

Читайте также

Составить программу в паскале по подсчету кол-ва претендентов, которые попадут в школьную баскетбольную команду,если рост игрока должен быть не менее

170 см. Считать число претендентов случайном числом в диапазоне от 150 до 200, число претендентов 50 (программу писать через массив)

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "составить программу нахождения суммы всех нечетных отрицательных элементов массива,образованного случайными числами в диапазоне от -30 до 30(на языке", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.