Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Среди 20 вводимых чисел выберите все кратные 2 или кратные 5 и подсчитайте их сумму.

5-9 класс

111075 28 нояб. 2014 г., 11:32:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lion566
28 нояб. 2014 г., 13:10:49 (9 лет назад)

var a:array[1..10] of integer;
s,s1:longint;
i,n:integer;
begin
n:=10;
s:=0; s1:=0;
for i:=1 to n do
begin
writeln('Vvedite element ',i);
read(a[i]);
end;
for i:=1 to n do
begin
write(a[i]:4);
end;
writeln;
for i:=1 to n do
begin
begin
if (a[i] mod 2=0) then s:=s+a[i];
end;
begin
if (a[i] mod 5=0) then s1:=s1+a[i];
end;
end;
writeln('Summa kratnix 2 = ',s);
writeln('Summa kratnix 5 = ',s1);
end.

Ответить

Другие вопросы из категории

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

Читайте также

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.



Вы находитесь на странице вопроса "Среди 20 вводимых чисел выберите все кратные 2 или кратные 5 и подсчитайте их сумму.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.