Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Пожалуйста, помогите!!! Выяснить, сколько раз в числе встречается цифра 3. Написать программу, желательно, с циклом while.

5-9 класс

Milawkahappy 24 авг. 2015 г., 4:46:36 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DoctorKull
24 авг. 2015 г., 6:15:52 (8 лет назад)

program war;
var a,i,j:integer;
begin
readln(a);
i:=0;
while a<>0
do
begin
j:=a mod 10;
if j=3 then
i:=i+1;
a:=a div 10;
end;
writeln(i);
readln
end.

Ответить

Другие вопросы из категории

Пятиклассник Вовочка однажды в кино увидел такую сцену – несколько мошенников обыгрывали зевак в игру с монетками. На столе находилась 21 монетка и

ведущий предлагал сыграть с ним по следующим правилам – нужно брать по очереди 1-2-3-4 монетку и кто берет последнюю, тот и проиграл. При этом ведущий благосклонно предлагал первым ходить игроку. Вовочка уже и не помнил про что был этот фильм, но вот игру запомнил и старается понять как это ведущий всегда выигрывает…Попробуйте и Вы понять, как правильно играть в эту игру и определить сможет ли ведущий выиграть у Вас, если Вы играете правильно при следующих количествах монеток на столе: 45, 53, 74, 113.В ответе укажите 4 слова с большой буквы Да или Нет. Да – если выиграет ведущий, Нет – если выиграете вы.

Решите пожалуйста номера 16 и 17

Читайте также

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

• 1В процессе преобразования растрового графического изображения количество цветов уменьшилось с 64 до 8. Во сколько раз уменьшился объем, занимаемый

им в памяти. Контрольная работа по теме «Компьютерная графика» 2 вариант • 2Мультимедиа – это А) получение движущихся изображений на дисплее; Б) прикладная программа для создания и обработки рисунков; В) объединение высококачественного изображения с реалистическим звуком; Г) область информатики, занимающаяся проблемами рисования на ЭВМ. • 3Выберите правильную последовательность этапов развития компьютерной графики: а) Появление графических дисплеев; b) Символьная графика; c) Появление графопостроителей; d) Появление принтера цветной печати. А) a, c, d, b; Б) b, c, a, d; С) b, a, c, d; Г) a, b, d, c. 3. Созданием произвольных рисунков, чертежей занимается А) научная графика; Б) конструкторская графика; В) деловая графика; Г) иллюстративная графика. 4. Какое устройство компьютера осуществляет процесс дискретизации звука? А) звуковая карта; Б) колонки; В) наушники; Г) процессор. 5. Растровое изображение представляет из себя … А)мозаику из очень мелких элементов — пикселей; Б) сочетание примитивов; В) палитру цветов. 6. Точка графического экрана может быть окрашена в один из цветов: красный, зелёный, коричневый, чёрный. Какой объём видеопамяти будет выделен для кодирования каждого пикселя? А) 4 бита; Б) 2 байта; В) 4 байта; Г) 2 бита; Д) 3 бита. 7. Инструментом ГР является: А) Линия; Б) цвет; В) разбрызгиватель; Г) рисунок. 8.Графическим примитивом является: А)линия; Б)ластик; В) копирование; Г)цвет. 9. Для получения 4-х цветного изображения на каждый пиксель необходимо выделить А) 1 байт ; Б) 1 бит; В) 2 байта; Г) 2 бита 10.Дискретный сигнал – это …А) цифровой сигнал; Б) количество измерений, производимых прибором за 1 секунду; В) непрерывно меняющееся со временем значение физической величины; Г) таблица с результатами измерений физической величины в фиксированные моменты времени. 11. При какой частоте дискретизации происходит более точное воспроизведение звука? А) 44,1 кГц; Б) 11 кГц; В) 22 кГц; Г) 8 кГц. 12. Что можно отнести к недостаткам растровой графики по сравнению с векторной? А) Большой объём графических файлов. Б) Фотографическое качество изображения. В) Возможность просмотра изображения на экране графического дисплея. Г) Искажения при масштабировании. 13.Что можно отнести к недостаткам ж\к монитора? А) малый вес; Б) затемнения при изменении угла обзора; В) отсутствие э/м излучения; Г) малый объем. • 14Для кодирования зелёного цвета служит код 1011. Сколько цветов в палитре? • 15Найдите объём записываемого звукового квадроаудиофайла, если запись велась 4 минуты, с использованием 16-битовой глубины кодирования звука и частотой дискретизации 32кГц. • 16Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения? • 17 В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?



Вы находитесь на странице вопроса "Пожалуйста, помогите!!! Выяснить, сколько раз в числе встречается цифра 3. Написать программу, желательно, с циклом while.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.