Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано некоторое число k. Указать количество элементов массива, превышающих k. массив из 10 чисел

5-9 класс

арина1618 12 апр. 2013 г., 20:43:40 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Beronuka
12 апр. 2013 г., 23:43:09 (11 лет назад)

Program Task;
Var a: Array [1..10] of Integer;
k, c, i: Integer;
Begin
Randomize;
For i := 1 To 10 Do
a[i] := Random(10);
WriteLn('Массив:');
For i := 1 To 10 Do
Write(a[i], ' ');
WriteLn;
Write('k = ');
ReadLn(k);
For i := 1 To 10 Do
If a[i] > k Then
c := c + 1;
WriteLn('Количество элементов: ', c);
ReadLn;
End.

Ответить

Читайте также

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)

составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в

строку данный массив. Найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах



Вы находитесь на странице вопроса "Дано некоторое число k. Указать количество элементов массива, превышающих k. массив из 10 чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.