Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите составить программу) задание во вложении

5-9 класс

Mrssweetpanda1 12 апр. 2015 г., 16:43:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nshlyeva45
12 апр. 2015 г., 17:59:37 (9 лет назад)

Т.к. в программе забыли проверить будет ли y > -2 то она скажет, что точка  x0 = 1; y0 = -3;

будет принадлежать квадрату хотя это не так

 

// программа

 

var

  x0, y0:real;

begin

  readln(x0, y0);

  if x0 < 2 then

  begin

    if x0 > -2 then

      if y0 < 2 then

        if y0 > -2 then  //нужно добавить это строку

          Writeln('точка лежит внутри области')

        else                                                                      // и блок начиная этим

          Writeln('точка не лежит внутри области')

      else         

        Writeln('точка не лежит внутри области')

    else         

      Writeln('точка не лежит внутри области'); // и заканчивая этим

  end

  else

      Writeln('точка не лежит внутри области');

end.

 

 

 

// доработаная

 

var

  x0, y0:real;

begin

  readln(x0, y0);

  if (x0 < 2) and (x0 > -2) and (y0 < 2) and (y0 > -2)  then

     Writeln('точка лежит внутри области')

  else

     Writeln('точка не лежит внутри области');

end.

 

 

+ 0 -
Nastya1837
12 апр. 2015 г., 18:46:15 (9 лет назад)

1) неверна при x=1, y=-3

2) нужно добавить условие проверки y > -2

 

3)

 

var x, y : real;

begin

readln(x, y);

if (x > -2) and (x < 2) and (y > -2) and (y < 2) then

writeln('лежит внутри области')

else

writeln('не лежит внутри области');

end.

 

Ответить

Читайте также

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.



Вы находитесь на странице вопроса "помогите составить программу) задание во вложении", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.