Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать на языке Паскаля. Даны числа.Найти сумму отрицательных чисел

5-9 класс

Sany007 02 мая 2015 г., 2:40:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kosm0na8t
02 мая 2015 г., 4:13:48 (9 лет назад)

var a,b,c,d:integer;
begin
readln(a);// кол во чисел
for b:=1 to a do
begin
readln(c);
If c<0 then d:=d+c;
end;
writeln(d);
end.

+ 0 -
Love1234555
02 мая 2015 г., 6:55:37 (9 лет назад)

var s,a,i,n:integer;
begin
write(n);
for i:=1 to n do begin
read(a);
if a<0 then s:=s+a;
end;
write(s);
end.

+ 0 -
Liamzain
02 мая 2015 г., 8:07:59 (9 лет назад)

Комментарий удален

+ 0 -
Ice79desh
02 мая 2015 г., 10:55:10 (9 лет назад)

Комментарий удален

Ответить

Читайте также

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.

Нужно написать программу на языке Паскаля!

Вот задача:
Найти сумму цифр данного числа

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.



Вы находитесь на странице вопроса "Написать на языке Паскаля. Даны числа.Найти сумму отрицательных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.