Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Разработайте

10-11 класс

алгоритм для вычисления площади крута: s = πr2.

Sashataranov4 25 окт. 2013 г., 12:37:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lavp
25 окт. 2013 г., 15:11:39 (10 лет назад)

Лень писать алгоритм поэтому напишу программу на паскале. Прочитаешь код поймешь алгоритм.
program sokr;
var a,b:real;
begin
writeln('Введите радиус');
readln(a);
b:=(a*a)*3.14;
writeln('Площадь круга равна ',b);
end.

Ответить

Другие вопросы из категории

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.1.Вычисляются два числа

- сумма первых трёх цифр и сумма последних трёх цифр.2.Полученные два числа записываются друг за другом в порядке не убывания (без разделителей).Пример.Исходное число:15177.Поразрядные суммы: 7 ,15.Результат: 715.Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата.2626 2618 2624 2628 2826 2426 1826 610.В ответ запишите только количество чисел ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!

Program1.pas(17) : Нельзя изменять значение переменной цикла внутри этого цикла

Помогите исправить ошибку .
Program Lin_10;
uses crt ;
type mas = array [1..9,1..9] of integer ;
var D,b:mas;
i,j,t,min:integer ;
Begin
clrscr;
Randomize ;
for i:=1 to 9 do begin
for j:=1 to 9 do begin
D[i,j]:=random(30)-60;
Write(D[i,j]:4);
End;
Writeln;
Writeln(' Задача 10_1 ') ;
for i:=1 to 9 do
for j:=1 to 9 do begin
min:=D[i,j];
End;
If min>D[i,j] then min:=[i,j];
End;
Writeln ;
Writeln('Min=',min);
Writeln(' Задача 10_2 ');
for i:=1 to 9 do begin
for j:=1 to 9 do begin
If (D[i,j] mod 2) = 0 then
D[i,j]:=0 ;
Write(D[i,j]:4);
End; Writeln;
Writeln(' Задача 10_3 ');
t:=1;
for j:=1 to 9 do begin
i:=j;
B[t]:=D[i,j];
t:=t+1;
u:=t; End;
For t:=1 to u-5 do begin
Write (D[t]:4);
End;
Writeln;
Writeln(' Задача 10_4 ');
Writeln(' Задача 10_5 ');
sum:=0;
for i:=1 to 9 do
For j:=1 to 9 do begin
If D[i,j] mod 3 = 0 then
Sum:=sum+D[i,j];
End;
Write('sum=',sum);
Readln;
End;

Дана матрица размерностью n*m.

найти в каждой строке max и min элемент

Паскаль

Дан массив размера n и целые числа К и 1 (1? K? 1?n) . Найти сумму элементов массива с номерами от К до 1 включительно.

Читайте также

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать алгоритм для X=5 и Y=-11.

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

Задание: разработать программу вычисления выходного значения функ-ции y=f(x1,x2,x3,x4). Тип входных и выходных данных, вид функции заданы в табл. 2.

Выходное значение и входные должны отображаться на экране в виде: X1= X2= X3= X4= Y=

Разработать функцию, которая автоматически заполняет массив из 10 наборов входных данных. Массив затем подвергается обработке, т.е. в цикле вычисляются значения функции и выводятся на экран в виде: Y1= Y2= Y3= Y4= , и т.д.

тип входных данных: целое тип выходных данных: целое, функция: x1*sin(x2) + x3*sin(x4)

ЛБ- 70 Разработайте алгоритм для вычисления площади треугольника: s = 1/2ah, где а – длина основания треугольника, h – его высота.

ВБ- 71 Разработайте схему алгоритма, который проверяет, не превосходит ли сумма двух действительных чисел А и В числа 100. Если не превосходит, установить значение флага F=0, иначе установить значение флага F=1. Вывести значение F.

ЦА-10 Разработайте схему алгоритма для вычисления суммы S первых n целых чисел. Предусмотрите ввод значения n с клавиатуры. Текущее значение целого числа имеет имя i (i = 1, 2, .., n).

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.



Вы находитесь на странице вопроса "Разработайте", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.