Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите Пожалуйста программу через TurboPascal Дан бинарный массив.Найти минимальный эллемент массива и поменять его с последним

10-11 класс

Smaylik7 16 нояб. 2013 г., 19:57:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tatlapygina
16 нояб. 2013 г., 21:18:46 (10 лет назад)

Паскаль

Откомпилирован в: Pascal ABC

 

program z1;
uses crt;
const m = 50;

//Задаем массив заранее большего значения, что массив не переполнился

var
   n: integer;
   i: integer;
   mas: array [0..m] of integer;
   buf: integer;
   min, imin: integer;
begin
    randomize;  //Запускаем функцию случайного значения
    write(' Введите количество элементов в массиве :  ');

//Вводим количество показываемых элементов
    readln(n);
   
    writeln();
    writeln(' Исходный массив:  ');
    for i := 1 to n do
    begin
         mas[i] := random(100);

//Заполняем массив случайными числами в диапозоне от 0 до 100
         writeln(' ',i,' = ', mas[i]); //Выводим их на печать
    end;
   
    min := mas[1]; //Начало минимального элемента. Предпологаем, что 1-ый элемент минимален
    for i := 2 to n do //Начиная со 2-го сравниваем 1-ый с дургими
    if min > mas[i] then //Если элемент меньше записываем его в минимальный
    begin
          min := mas[i]; //И так сравниваем все элементы друг с другом
          imin := i //Берем индекс минимального для дальнейшего использования
    end;
    buf := mas[n]; //Присваиваем переменной значение последнего элемента
    mas[n] := min; //Присваиваем последний элемент значению минималньго
    mas[imin] := buf; //Теперь место минимальнго занимает значение последнего

    writeln();
    writeln(' Отсоритрованный по правилу, что минимальный элемент в конце:  ');
    for i := 1 to n do
    begin
         writeln(' ',i,' = ', mas[i]); //Выводим весь массив
    end;
end.

Ответить

Другие вопросы из категории

Как это сделать в Excel?

Ввести с клавиатуры 3 числа, найти среди них
наименьшее. Предусмотреть выводы данных на дисплей.

Разработайте

алгоритм для вычисления площади крута: s = πr2.

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.1.Вычисляются два числа

- сумма первых трёх цифр и сумма последних трёх цифр.2.Полученные два числа записываются друг за другом в порядке не убывания (без разделителей).Пример.Исходное число:15177.Поразрядные суммы: 7 ,15.Результат: 715.Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата.2626 2618 2624 2628 2826 2426 1826 610.В ответ запишите только количество чисел ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!

Program1.pas(17) : Нельзя изменять значение переменной цикла внутри этого цикла

Помогите исправить ошибку .
Program Lin_10;
uses crt ;
type mas = array [1..9,1..9] of integer ;
var D,b:mas;
i,j,t,min:integer ;
Begin
clrscr;
Randomize ;
for i:=1 to 9 do begin
for j:=1 to 9 do begin
D[i,j]:=random(30)-60;
Write(D[i,j]:4);
End;
Writeln;
Writeln(' Задача 10_1 ') ;
for i:=1 to 9 do
for j:=1 to 9 do begin
min:=D[i,j];
End;
If min>D[i,j] then min:=[i,j];
End;
Writeln ;
Writeln('Min=',min);
Writeln(' Задача 10_2 ');
for i:=1 to 9 do begin
for j:=1 to 9 do begin
If (D[i,j] mod 2) = 0 then
D[i,j]:=0 ;
Write(D[i,j]:4);
End; Writeln;
Writeln(' Задача 10_3 ');
t:=1;
for j:=1 to 9 do begin
i:=j;
B[t]:=D[i,j];
t:=t+1;
u:=t; End;
For t:=1 to u-5 do begin
Write (D[t]:4);
End;
Writeln;
Writeln(' Задача 10_4 ');
Writeln(' Задача 10_5 ');
sum:=0;
for i:=1 to 9 do
For j:=1 to 9 do begin
If D[i,j] mod 3 = 0 then
Sum:=sum+D[i,j];
End;
Write('sum=',sum);
Readln;
End;

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

дан целочисленный массив из n элементов A(n) в пределах от -20 до 20.Найти сумму тех чисел,которые кратны 5

напишите пожалуйста программу на паскале и блок схему!)

плохо очень знаю С++ оч надо решить задачи

1)дан одномерный массив заполнит его так чтобы получилась геометрическая прогрессия где первый член равен 2, d=-3 и вывести в столбец.
2)вывести массив в строку и найти минимальный элемент массива.
3)отсортируйте его по возрастанию и вычислите произведение элементов массива.

Для некоторых это будет легко,но для меня трудно.У меня идеи есть,но до сих пор не получается реализовать,чтобы все работало.

Я прошу помочь с выполнением задачи.
Напишите пожалуйста код в C++, который делает следующее:
Найти номер элемента массива,модуль разности сумм чисел слева и справа от которого наименьший.Значение элемента с этим номером при суммировании не учитывается.Номера элементов начинаются с 0.
Допустим элементы последовательности такие : 1,2,3,4,5,6,2.
Ответ:номер элемента 4.,т.е. это число 5 последовательности.
Помогите пожалуйста написать код.



Вы находитесь на странице вопроса "Напишите Пожалуйста программу через TurboPascal Дан бинарный массив.Найти минимальный эллемент массива и поменять его с последним", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.