Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано 9-значное целое число. Найти среднеарифметическое цифр с 5-ой по 7 включительно

10-11 класс

Сделайте срочно в Паскале!

Лина203 26 окт. 2014 г., 19:13:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
спсрпмтпмори
26 окт. 2014 г., 21:13:46 (9 лет назад)

123456789
5
6
7
program gt;
var n,a,b,c:integer;
s:real;
begin
readln(n);
a:=(n mod 100000)div 10000;
b:=(n mod 10000)div 1000;
c:=(n mod 1000)div 100;
s:=(a+b+c)/3;
writeln(s);
end.

+ 0 -
Nrodnaia
26 окт. 2014 г., 22:12:06 (9 лет назад)

с 5-7 3 числа поэтому S:=(a+b+c)/3 a,b,c-цифры с 5 по 7

Ответить

Другие вопросы из категории

В некоторой информационной системе информация кодируется двоичными шестиразрядными словами. При передаче данных возможны их искажения,

поэтому в конец каждого слова добавляется седьмой (контрольный) разряд таким образом, чтобы сумма разрядов нового слова, считая контрольный, была чётной. Например, к слову 110011 справа будет добавлен 0, а к слову 101100 – 1.

Пожалуйста, в бейсике
Вторая цифра шестнадцатеричного четырехзначного числа равна 1. Первую цифру переставили в конец числа. Полученное число оказалось на 2EB3 (16с.с.) меньше

исходного. Исходное число, записанное в системе счисления по основанию 16, равно ____? Чему равно, помогите пожалуйста решить...

Что такое ЗУ в компьютере?

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа

E,иначе из числа взять корень степени, равной второй цифре числа

если есть умеющте напишите,пожалуйста,программу в Паскале

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.



Вы находитесь на странице вопроса "Дано 9-значное целое число. Найти среднеарифметическое цифр с 5-ой по 7 включительно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.