Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.одномерные массивы

5-9 класс

Напишите программу на Паскале.ВЫвести на экран номера всех элементов массива B[1..n],не совподающих с максимальным

помогите

Ekaterinamusino 25 апр. 2015 г., 8:20:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AKEKS7452
25 апр. 2015 г., 9:09:06 (9 лет назад)

uses crt;
var max,n,i:integer;
b:array[1..100] of integer;
begin
writeln('Введите N и элементы массива:');
read(n);
read(b[1]);
max:=b[1];
for i:=2 to n do
begin
read(b[i]);
if b[i]>max then
max:=b[i];
end;
for i:=1 to n do
if b[i]<>max then
write(b[i],' ');
end.

Ответить

Читайте также

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов. Найти сумму элементов массива, кратных данному числу К.

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.

1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив

отрицательные элементы начального массива.
с применение подпрограмм и процедур желательно



Вы находитесь на странице вопроса "1.одномерные массивы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.