Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти среднее арифметическое чисел стоящих на нечетных местах и подсчитать количество чисел меньших заданного С.

5-9 класс

Тема: работа с одномерными массивами.

GansVictory 09 мая 2015 г., 13:13:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Saramira
09 мая 2015 г., 14:43:42 (9 лет назад)

var
  a: array [1..25] of integer;
  c, i, S: integer;

begin
  for i := 1 to 25 do
  begin
    a[i] := random(25);
    write(a[i], ' ');
    if (a[i] mod 2 = 1) then
    begin
      S += a[i];
      c += 1;
     end;
  end;
  writeln();
  writeln(S / c, #13);
  readln(c);
  S := 0;
  for i := 1 to 25 do
    if (a[i] < c) then s += 1;
  writeln(S);
end.  

Ответить

Другие вопросы из категории

1. Укажите тип ссылки: G23 $F$10 H$4

2. В ячейке А1 содержится формула =$D2-C2. Как изменится эта формула при копировании ее из ячейки А1 в ячейку A2?
3. Укажите выражение, которое может быть формулой Excel.а) =А5+5$б) А$123+65в) =$А$6+$7$Сг) =А$1

4. Приведите примеры ссылок: относительной, абсолютной, смешанной.
5. В ячейку E5 ввели формулу =$A$5*B5. Затем эту формулу распространили вниз. Какая формула содержится в ячейке Е8?

Дан фрагмент электронной таблицы. Какая формула может быть записана в ячейке D2, чтобы построенная после

выполнения вычислений диаграмма по значениям диапазона ячеек A2:D2
соответствовала рисунку:

НАПИСАТЬ ПРОГРАММУ.

Угадай число. Один из партнеров вводит в программу число, а второй должен отгадать это число. Причем на каждый предложенный вариант программа отвечает либо «больше», либо «меньше» до тех пор, пока число не будет отгадано. Вывести количество попыток, которое было сделано.

Читайте также

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

помигите с ивт

1)дан массив четных чисел ,определить сумму элементов которые делятся на 5 ,стоящих на нечетных местах.
2)Дано число и массив, найти количесвто элементов , равных данному числу

cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего

элемента исходного массива, в полученном массиве вывести элементы стоящие на нечетных местах. Напишите, пожалуйста программу на языке Pascal



Вы находитесь на странице вопроса "Найти среднее арифметическое чисел стоящих на нечетных местах и подсчитать количество чисел меньших заданного С.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.