Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Одномерные массивы.

5-9 класс

Дан массив натуральных чисел, состоящий из n элементов. Найти сумму элементов массива, кратных данному числу К.

TheDigle1 29 марта 2014 г., 10:21:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ВалераЛукин30
29 марта 2014 г., 12:54:27 (10 лет назад)

Uses crt;
Const n = 10;
Var   a: array[1..n] of integer;
  i: byte;  
 sum: integer;
Begin  
ClrScr;
  For i:=1 to n do  
  Begin      
Write('a[',i,'] = ');    
  ReadLn(a[i]);    
End;  
 ClrScr;  
For i:=1 to n do
write(a[i],' ');
  WriteLn;
  For i:=1 to n do  
  If a[i] mod 2 = 0 then inc(sum,a[i]);
  WriteLn('сумма элементов, кратных двум: ',sum);  
 ReadKey
End.( вот например кратный двум...аналогично) 

+ 0 -
Sslapovskaya
29 марта 2014 г., 14:45:56 (10 лет назад)

var
  s,i,k:integer;
  m:array[1..20]of integer;
begin
write('Введите k: ');
readln(k);
writeln('Массив:');
for i:=1 to 20 do
  begin
  m[i]:=random(20);
  write(m[i],' ');
  if m[i] mod k=0  then s:=s+m[i];
  end;
writeln;
writeln('Ответ: ',s);
end.

Ответить

Другие вопросы из категории

Решите пожалуйста,в конструкторе

алгоритмов:

в одномерном массиве произвольных чисел требуется заменить числом 100 значения всех элементов, удовлетворяющих условию A[i]>=5

Дан фрагмент алгоритма для вычисления:

а:= 7
b:= 16
если (а - b >/= а)
то с:= b + 2 * a
иначе с:= b - 2 * a
с:= 10 + с/2
Выполните предложенный фрагмент алгоритма. Какое значение будет иметь переменная "с" после выполнения этого фрагмента?

ПОМОГИТЕ ПОЖАЛУЙСТА ОТВЕТЫ!!!!

Дано: x=1F416 , y=7018
. Какое из чисел Z, записанных в двоичной системе
счисления, удовлетворяет неравенству y 1) 1111110012 2) 1111001112 3) 1101111002 4) 1101101112

Дано: a=101101112
, b=A616 . Какое из чисел С, записанных в двоичной системе
счисления, удовлетворяет неравенству b 1) 101110102 2) 101010102 3) 1010101002 4) 101000102


Дано: a=111001102
, b=2718
. Какое из чисел С, записанных в шестнадцатеричной
системе счисления, удовлетворяет неравенству a>C>b ?
1) AA16 2) B816 3) D616 4) F016


Читайте также

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.

1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив

отрицательные элементы начального массива.
с применение подпрограмм и процедур желательно

1.одномерные массивы

Напишите программу на Паскале.ВЫвести на экран номера всех элементов массива B[1..n],не совподающих с максимальным

помогите



Вы находитесь на странице вопроса "Одномерные массивы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.