Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано произвольная символьная строка.Узнать её длинну и копировать из строки S 3 символа начиная с позиции 4.

5-9 класс

Khusnutdiova 24 сент. 2015 г., 18:58:03 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lupova97
24 сент. 2015 г., 20:17:07 (8 лет назад)

var s,a:string;
i,d:integer;
begin
d:=0;
write('Введите что угодно:');
readln(s);
for i:=1 to length(s) do
 d:=d+1;
writeln('Длина строки:',d);
a:=copy(s,3,4);
writeln(a);
end.

+ 0 -
PomogimHe
24 сент. 2015 г., 21:16:49 (8 лет назад)

Исправим ошибки в коде выше.

uses crt;

var s:string;
begin
write('Введите строку:');
read(s);
writeln('Длина строки:',length(s));
writeln(copy(s,4,3));
end.

Вот так работает корректней.

Ответить

Другие вопросы из категории

Срочно нужна помощь!!

1. С клавиатуры вводят слово и символ. Составть программу, которая:
а) проверяет, есть ли в этом слове заданный символ;
б) определяет позицию заданного символа;
в) подсчитывает количество вхождений заданного символа.
2. С клавиатуры вводят строку и слово. Составть программу, которая:
а) определяет позицию заданного слова;
б) удаляет заданное слово;
в) вставляет в строку заданное слово.
3. Составть программу, которая:
а) из строки "Волга, Днепр, Неман, Енисей" удаляет названия рек, не протекающих по территории Беларуси;
б) из строки "Брест, Бобруйск, Витебск, Гомель, Мозырь, Могилев" удаляет названия городов, не являющихся областными центрами.
4. Составть программу, которая:
а) в строке "край озер" добавляет слова "лесов и рек";
б) в строке "я учусь в школе" заменить слова "в школе" на "в 10-ом классе".
5. Составть программу, которая переставляет на первое место:
а) в строке "моя родина Беларусь" слово "Беларусь";

б) в строке "люблю цябе мой родны кут" слова "мой родны кут".

Задача1Введите числа в переменные a, b и c и напишите программу, которая меняет местами значения переменных по следующей схеме, чтобы в переменной а

оказалось первоначальное значение переменной с, в переменной b – значение а, в переменной с – значение b.
Написать программу в pascal abc

Читайте также

Запишите строку русских букв ,про которую неверно не одно из утверждений:

1. её длина больше 7
2.её длина меньше 5
3. в этой строке встречаются две гласные буквы стоящие рядом
4.строка начинается с гласной буквы
5в строке нет ни одной буквы А
6.в строке есть только одна из букв А, Б, В

Задача №3 (Владения рыцаря)

Английская система
мер1 миля 1760 ярдов
1 ярд 3 фута
1 фут 12 дюймов
1 дюйм 12 линий
Рыцарь сэр Джон купил новый замок и послал двух своих слуг измерить периметрсвоего нового владения. Один измерял длину другой ширину. Выяснилось, что оградаявляется точным прямоугольником. Требуется написать программу, которая подсчитаетпериметр.Формат входных данных:ввод производить в виде двух строк. в каждой из строк записан результат измеренийслуги. При этом каждая величина записана в формате:M Y F D L, где M (0 <= M <= 10000)- мили, Y (0 <= Y <= 1760)- ярды, F - (0 <= F <= 3)футы, D - (0 <= D <= 12) дюймы, L - (0 <= L <= 12) линии. (Отсутствующее числозаменяеться на 0)
Ври выводе использовать сокращенные меры - миля=мл. ярды = ярд. фут=фт.дюймы=фт. линии=лн.
Примеры вводных и выходных данных:
ВВОД:1 3 2 11 011 0 0 0 0
ВЫВОД: 24 мл. 7 ярд. 2 фт. 10дм. 0лн

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.



Вы находитесь на странице вопроса "Дано произвольная символьная строка.Узнать её длинну и копировать из строки S 3 символа начиная с позиции 4.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.