Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Pascal

10-11 класс

Организовать меню: 1) вычислить значение y=sinx 2) y=cosx 3) выход

MashaOops55 14 февр. 2015 г., 23:59:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vozovski
15 февр. 2015 г., 1:36:41 (9 лет назад)

program D1KPxx18;
uses crt;
var
x,y,a:real;
label 1,2,3,4;
begin
4:writeln('Выберите что вам нужно: 1-синус числа, 2-косинус числа, 3-выход');
read(a);
if a=1 then
goto 1;
if a=2 then
goto 2;
if a=3 then
goto 3;
1:begin
writeln('Введите "х"');
read(x);
y:=sin(x);
writeln('Синус "х" равен  ',y);
writeln('Ещё? 1-No, 2-Yes');
read(a);
if a=2 then goto 4
else goto 3;
end;
2:begin
writeln('Введите "х"');
read(x);
y:=cos(x);
writeln('Косинус "х" равен ',y);
writeln('Ещё? 1-No, 2-Yes');
read(a);
if a=2 then goto 4
else goto 3;
end;
3:writeln('Пока!');
end.


Программа основана на метках, перемещая метки можно переходить к разным местам программы, тем самым использую их как меню... это если я правильно понял что именно значило:"Организовать меню")))

+ 0 -
Makkamov41
15 февр. 2015 г., 3:43:46 (9 лет назад)

организовать меню-это что? типа чтобы было выбрать там что именно нужно из этих 3-х? синус, косинус или выход?

+ 0 -
Sadyrova2005
15 февр. 2015 г., 5:18:27 (9 лет назад)

Если я правильно понял то:

+ 0 -
Nicemukhametzy
15 февр. 2015 г., 7:23:39 (9 лет назад)

смотри в ответе))) а то влом здесь распределять)))

+ 0 -
лара79
15 февр. 2015 г., 9:46:41 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите!!! Срочно!!!

Составить программу. Сформировать массив из 8 элементов, вывести количество отрицательных чисел.
Составить программу. Создать массив из 10 элементов случайным образом, найти сумму нечетных чисел.
Писать на языке Паскаль,одномерный массив

какое количество двоичных разрядов требуется чтобы закодировать 512 байт?

какое кол-во двоичных разрядов требуется, чтобы закодировать одну из 64 клеток шахматной доски?

Привет, помогите пожалуйста.

Форм факторы Блоков Питания AT, ATX, ATX-12V.
,Можете назвать их отличия между собой, кто чем отличается..

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

В языке Pascal есть функция Pandom (a), которая служит для получения случайного ряда чисел из интервала (0;а). Вопрос: придумать, как можно при помощи

формул языка Pascal сделать так, чтобы случайные числа выпадали в интервале (a;b)

Скажите по конкретнее, что нужно знать чтобы научиться программировать в Pascal - что именно нужно изучить...

У нас на первом курсе тема Pascal, а я гляжу на него как баран на новые ворота...
Я отстал сильно на 2 недели и ни могу ни как понять его... Скажите пожалуйста по конкретнее с чего начать, что именно нужно изучить или выучить, понять, чтобы знать как составлять на нём программы ?

ЗАДАЧА ДЛЯ PASCAL ABC: В группе 30 учеников. За выполненный тест они могут

получить от 5 до 15 баллов (Сгенерить случайные числа

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.



Вы находитесь на странице вопроса "Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.