Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

PascalABC выдает ошибку,где она?!(Сама задача:Дано двузначное число. Найти сумму и произведение его цифр)

5-9 класс

Var a,b,c:integer;
Begin
Readln(a);
b:= a div 10;
c:= a mod 10;
writeln('сумма цифр числа',a,'равна',b+c,'произведение равно'b*c)
end.

Анастасэйшен 15 окт. 2013 г., 13:15:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polina26052014
15 окт. 2013 г., 13:54:53 (10 лет назад)

Ваша ошибка вот в этом операторе:
writeln('сумма цифр числа',a,'равна',b+c,'произведение равно'
<ТУТ ПРОПУЩЕНА ЗАПЯТАЯ> b*c)

Ответить

Другие вопросы из категории

Читайте также

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

ПОМОГИТЕ! БУДЬТЕ ЛЮДЬМИ!

Задачи на целочисленное деление (div) и остаток от целочисленного
деления(mod).
Integer 11. Дано трехзначное число. Найти сумму и произведение его цифр.
Integer 20. С начала суток прошло N секунд. Найти количество полных часов, прошедших
с начала суток.

ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!

Решить задачи на турбопаскале:
1.Дано натуральное число Найти сумму и произведение первых двух чисел.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

Задача1

Дано двузначное число. Найти сумму и произведение его цифр



Вы находитесь на странице вопроса "PascalABC выдает ошибку,где она?!(Сама задача:Дано двузначное число. Найти сумму и произведение его цифр)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.