Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте програму, которая вводит с клавиатуры длину и ширину прямаугольника и определяет, является ли прямаугольник квадратом. Постройте данный

5-9 класс

прямоугольник ( единицу длины показать 5 пикселями)

Borez4567 10 мая 2015 г., 6:52:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Devk
10 мая 2015 г., 9:02:31 (9 лет назад)

uses crt,graphABC;
var x,y,xc,yc:integer;
begin
xc:=windowwidth div 2;
yc:=windowheight div 2;

write ('Введите ширину ');
read (x);
write ('Введите длину ');
read (y);

if (x=y) then write ('Это квадрат');
hidecursor;
setpencolor(clAqua);
rectangle(xc-x*5,yc-y*5,xc+x*5,yc+y*5);
floodfill(xc,yc,clAqua);
readkey;

end.

Ответить

Другие вопросы из категории

Помогите пожалуйста

Составьте программу,которая предлагает ввести с клавиатуры две строки s и t и выводит на экран более длинную строку.
Пример ввода:
школа (Строка s)
ученик (Строка t)
Пример вывода :
ученик

Читайте также

1)составьте программу ,которая предлагает ввести с клавиатуры две строки ,а затем выводит это строки на экран в алфавитном порядке

например армия(строка а)
арбуз (строка б)
2)составьте программу ,которая предлагает ввести с клавиатуры две строки а и б ,соеденяет их и выводит результат в одну строку
например: тепло(строка а)
ход(строка б)

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...



Вы находитесь на странице вопроса "Составьте програму, которая вводит с клавиатуры длину и ширину прямаугольника и определяет, является ли прямаугольник квадратом. Постройте данный", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.