Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найдите и выведите на экран все трехзначные числа, которые делятся без остатка на 11 и имеют в своей записи хотя бы одну цифру 3.

5-9 класс

Marmeladka99 30 авг. 2016 г., 17:30:03 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nesterova198143
30 авг. 2016 г., 19:04:54 (7 лет назад)

const n=10;
var a:array[1..n]of integer;
i,k,l,aa: integer;
begin
for i:=1 to n do readln(a[i]);
for i:=1 to n do
if (a[i] mod 11 =0) and (a[i]<1000) and(a[i]>99) then
begin
k:=0;
aa:=a[i];
for i:=1 to 3 do
begin 
l:=aa mod 10;
if l=3 then k:=1;
aa:=aa div 10;
end; 
if k=1 then writeln(a[i]);
end;
end.

Ответить

Другие вопросы из категории

Записать число в развернутой форме :

1000110,1101₂

Семья ночью подошла к мосту.Папа может перейти его за 1

минуту,мама-за 2,а малыш-за 5,а бабушка-за 10 минут.У них есть один
фонарик.Мост выдерживает только двоих.Как им перейти мост за 17
минут?(Если переходят двое,то они идут с меньшей из скоростей.Двигаться
по мосту без фонарика нельзя.Носить друг друга на руках нельзя).

Читайте также

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.

1.Найти произведение всех целых чисел от а до 100 (а<100) кратных 17,но не кратных 2 2.Вычислите: 98+96+94+92+90+88+,,,,,+6+4+2

3.Определить и вывести на экран количество трехзначных чисел,которые делятся без остатка на 5 и 21 одновременно.

4.спортсмен пробежал в 1-ый день тренеровки расстояние 10 км. В каждый следующий день он робегал на 3 км больше ,чем в предыдущий. Определить Суммарное расстояние.

5. в Пионерском лагере n отрядов с различным количеством детей. Сколько всего детей в пионерском лагере?

Найдите выведите на экран все трехзначные числа,кратные 20,сумма цифр которых равны сумме цифр частного от деления их на 20 Может так

>

uses crt;
var b,c,d,t,i,s,k:integer; o:real;
begin
s:=0;
for k:=100 to 1000000000 do
begin
b:=k mod 10;
c:=k div 100;
d:=(k mod 100)div 10;
t:=d+b+c;
o:=(b div 20)+(c div 20)+(d div 20);
if ((k mod 20)=0) and (t=o) then s:=s+1;
end;
writeln('s=',s);
end.

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!



Вы находитесь на странице вопроса "Найдите и выведите на экран все трехзначные числа, которые делятся без остатка на 11 и имеют в своей записи хотя бы одну цифру 3.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.