Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

ПАСКАЛЬ Abc

5-9 класс

придумать и решить задачу с применением условия "or".

Kuminovslava1 09 янв. 2015 г., 11:01:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelina11042003
09 янв. 2015 г., 12:13:35 (9 лет назад)

пишу как в Турбо Паскале 7.0(они не много отличаются)

{С Клавиатуры вводится 3-x значное число. Разбить это число на цифры. Если какое-либо из чисел равно 0, то определите квадратный корень суммы 1 и 2 числа в противном случае напишите " нулей нет"}

 

program z1;

uses crt;

var x,y,z,a:integer;

begin

clrscr;

write(a=');

readln(a);

x:=a div 100;

y:=(a mod 10)mod 10;

z:=a mod 10;

if (x=0)or(y=0)or(z=0) then b:=SQRT(a+b) else writeln('нулей нет');

writeln(b);

readln;

end.

Ответить

Другие вопросы из категории

№1. Дан массив напечатать:

1)все неотрицательные элементы.
2)все элементы не превышающие числа 10

№2
дан массив целых чисел.Напечатать:
1)все элементы кратные 5
2)все элементы заканчивающиеся 0

После отключения питания компьютера сохраняется информация, находящаяся:

а) в оперативной памяти
б) в процессоре
в) во внешней памяти
г) в видеопамяти
Помогите пжл

Строки (цепочки символов латинских букв) создаются по следующему правилу.

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих цепочек создаётся такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывается предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD

Запишите шесть символов подряд, стоящих в восьмой строке с 10-го по 105-е место (считая слева направо).

Читайте также

Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2;3] и подсчитывает сумму

отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!

Помогите пожалуйста решить) Паскаль ABC)

Написать программу вычисления значений выражения:
а) 2 в степени 3+ 3 в степени 2+ 4 в степени 2/



Вы находитесь на странице вопроса "ПАСКАЛЬ Abc", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.