Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вводится последовательность из N целых чисел. Найти наименьшую по значению цифру в каждом числе (функцией оформить определение

10-11 класс

наименьшей цифры числа).

Valyushafedoro 15 июня 2013 г., 12:18:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
рома1325100
15 июня 2013 г., 14:28:11 (10 лет назад)

Program Task;
Const N = 5;
Var a: Array [1..N] of LongInt;
    i: Integer;
Function MinDigit(number: LongInt): Integer;
Var digits: Array of Integer;
    num, min, i: Integer;
Begin
    num := number;
While num <> 0 Do
Begin
    num := num Div 10;
    i := i + 1;
End;
    SetLength(digits, i);
    num := number;
For i := 0 To Length(digits) - 1 Do
Begin
    digits[i] := num Mod 10;
    num := num Div 10;End;
For i := 0 To Length(digits) - 1 Do
    If digits[i] < digits[min] Then
    min := i;    Result := digits[min];
End;
Begin
    WriteLn('Введите ', N, ' целых чисел через пробел');
    For i := 1 To N Do
        Read(a[i]);
    For i := 1 To N Do
        Write(MinDigit(a[i]), ' ');
End.

+ 0 -
Аннаиюльская
15 июня 2013 г., 17:16:53 (10 лет назад)

c++

Ответить

Другие вопросы из категории

Помогите пожалуйста....

Вычислите в какой координатной четверти расположен треугольник,образованный прямой,заданной уравнением y=ax+b, и осями ординат. Числа a и b,что треугольник всегда существует
формат входных данных:
Входной файл INPUT TXT содержит заданные целые числа a и b (-100 меньше или равно a b но больше чем 100)
Выходной файл OUTPUT. TXT должен содержать номер четверти

Помоги решить...

В 16 системе

Укажи минимальный объём памяти (в килобайтах), достаточный для хранения любого растрового изображения размером 128×128 пиксела, если известно, что в

изображении используется палитра из 256 цветов. Саму палитру хранить не нужно.

Значения двух массивов A[1..10] и B[1..10] задаются с помощью следующего фрагмента программы: for i:=1 to 10 do A[i]:=10-i; for

i:=1 to 10 do

B[i]:=A[5] – A[i]

Сколько элементов массива будут иметь отрицательные значения?

1) 0 2) 5 3) 10 4) 4

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

В последовательности из 15 целых чисел найти максимальный элемент из четных.

Помогите пожалуйста написать программу)



Вы находитесь на странице вопроса "Вводится последовательность из N целых чисел. Найти наименьшую по значению цифру в каждом числе (функцией оформить определение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.