Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводится последовательность из 13 целых чисел. Найти среднее арифметическое чисел, меньших 9

10-11 класс

Denis84333 26 февр. 2015 г., 5:22:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
серж2405
26 февр. 2015 г., 7:53:21 (9 лет назад)

var

  i  : integer;

  val: integer;

  sum: integer;

  cnt: integer;

begin

  sum:=0;

  cnt:=0;

  for i:=1 to 13 do

    begin

      readln(val);

      if (val<9) then

        begin

          cnt := cnt + 1;11

          sum := sum + val;

        end;

    end;

  writeln(sum/cnt);

end.

+ 0 -
TanyaHulyk
26 февр. 2015 г., 9:03:02 (9 лет назад)

Паскаль.

 

uses crt;
var
  a,s,i,k:integer;
begin
  s:=0; k:=0;
  for i:=1 to 13 do
  begin
    write('Введите ',i,' число: '); read(a);
    if a<9 then
    begin
      s:=s+a; k:=k+1;
    end;
  end;
  write('Среднее арифметическое чисел, меньших 9: ',s/k);
end.

Ответить

Другие вопросы из категории

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

В последовательности из 15 целых чисел найти максимальный элемент из четных.

Помогите пожалуйста написать программу)



Вы находитесь на странице вопроса "С клавиатуры вводится последовательность из 13 целых чисел. Найти среднее арифметическое чисел, меньших 9", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.