Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны 3 числа a,b,c. Определить, имеется ли среди них хотя бы одна пара взаимно обратных чисел. ПОМОГИТЕ,ПОЖАЛУЙСТА!!!!!СРОЧНО НАДО!!!!!!!!!!!!!!!

10-11 класс

!!!!!!!!!!!!!

Elja24 26 янв. 2015 г., 19:35:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tomach
26 янв. 2015 г., 20:59:55 (9 лет назад)

VAR
   a,b,c: LongInt;
BEGIN
   Read(a,b,c);
   
   if (a*b = 1)or(a*c = 1)or(b*c = 1) then Write('ДА')
   else Write('НЕТ');
END.

Ответить

Другие вопросы из категории

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Читайте также

ПОЖАЛУЙСТА ОБЪЯСНИТЕ САМО РЕШЕНИЕ.НЕ НАДО ПИСАТЬ ПРОГРАММУ. Определить есть ли в массиве хотя бы одна тройка соседних чисел, в которой

средний элемент больше своих "соседей", т. е. предшествующего и последующего. В случае положительного ответа определить номера элементов первой из таких троек.

Помогите составить программу. Даны действительные числа х и у, Определить принадлежит ли точка с координатами х,у заштрихованной области. Рисунок

предоставляю.
мне просто надо словами описать как это делать. (ну или условие if и тп и тп.)

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».



Вы находитесь на странице вопроса "Даны 3 числа a,b,c. Определить, имеется ли среди них хотя бы одна пара взаимно обратных чисел. ПОМОГИТЕ,ПОЖАЛУЙСТА!!!!!СРОЧНО НАДО!!!!!!!!!!!!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.