Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста... хотя бы составить программу.

10-11 класс

Дано два натуральных числа N и M.
Написать программу для определения
наименьшего из чисел, составленных из цифр данных чисел. Незначащих
нулей в найденном числе быть не должно.

Формат входных данных:

КисаКисаКиса 21 июня 2016 г., 21:55:14 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sweet9708
22 июня 2016 г., 0:47:08 (7 лет назад)

var x, y, j, i,b,a:longint;
g, f: text;
begin
assign (g, 'input.txt');
assign (f, 'output.txt');
reset (g);
read (g, x, y);
close (g);
rewrite(f);
while x>=0 do begin
b:=(x mod 100) div 10;
if b=0 then break;
a:=x mod 10;
if a>b then a:=b;
x:=x div 10;
end;
while y>=0 do begin
j:=(y mod 100) div 10;
if j=0 then break;
i:=y mod 10;
if i>j then i:=j;
y:=y div 10;
end;
if a<i then write(f, a);
if a>i then write(f, i);
close (f);
end.

+ 0 -
Yliaka82
22 июня 2016 г., 2:29:43 (7 лет назад)

procedure ShellStr(var s: string);
{ сортирует символы строки методом Шелла }
var
  i, j, n, step: integer;
  c: char;
begin
  s := Trim(s);
  n := Length(s);
  step := n div 2;
  while step > 0 do
  begin
    for j := n - step downto 1 do
    begin
      i := j;
      while i <= n - step do
      begin
        if s[i] > s[i + step] then
        begin
          c := s[i];
          s[i] := s[i + 1];
          s[i + 1] := c
        end;
        i := i + step
      end
    end;
    step := step div 2
  end
end;

procedure TrimNullsLeft(var s: string);
{ Усекает левые (незначащие нули) в строке s }
var
  i, n: integer;
begin
  i := 1; n := Length(s);
  while (s[i] = '0') do i := i + 1;
  s := Copy(s, i, n - i + 1)
end;

var
  p, ns: integer;
  s, M, N: string;
  ml, nl: integer;
  f: text;

begin
  Assign(f,'input.txt');
  Reset(f);
  Readln(f,s);
  Close(f);
  Assign(f,'output.txt');
  Rewrite(f);
  ns := Length(s);
  p := Pos(' ', s);
  ml := p - 1;
  M := Copy(s, 1, ml);
  ShellStr(M);
  TrimNullsLeft(M);
  ml := Length(M);
  N := Copy(s, p + 1, ns - p);
  ShellStr(N);
  TrimNullsLeft(N);
  nl := Length(N);
  if ml < nl then Writeln(f,M)
  else if nl < ml then Writeln(f,N)
  else if M < N then Writeln(f,M) else Writeln(f,N);
  Close(f);
  Writeln('Программа завершила работу')
end.

+ 0 -
Reabko14
22 июня 2016 г., 5:04:36 (7 лет назад)

Что значит "хотя бы"? У Вас написано в задании составить программу... Что-то еще помимо программы подразумевается?

Ответить

Другие вопросы из категории

восстанови цепочку чисел

42 45 49 94 цепь

Программы - доктора это программы:

1) обнаруживающие файлы зараженные вирусом

2) уничтожающие тело вируса

3) сравнивающие текущее состояние диска с запомненным

4) Правильный ответ отсутствует

5) Все пунктаы верные

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает

файл каждая строка которого выглядет так: табельный номер,фио,оклад.

ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"



Вы находитесь на странице вопроса "Помогите пожалуйста... хотя бы составить программу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.