Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Клиент открыл счёт в банке 1 марта,вложив 1000 рублей.Каждый месяц размер вклада увеличивается на 2 процента.Определить за какой месяц величина

10-11 класс

ежемесячного увеличения вклада превысит 50 рублей.Напишите,пожалуйста,программу.

Antolypetroff2 14 февр. 2017 г., 17:49:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lesya98lesya
14 февр. 2017 г., 20:37:31 (7 лет назад)

Program vidcvnjiod;

uses crt;

var p,a:real;

      m:integer;

begin

clrscr;

a:=1000;

p:=(a*2)/100;

m:=3;

repeat

a:=a+p;

m:=m+1;

until a>1050;

m:=m mod 12;

case m of

0: writeln('декабрь');

1: writeln('январь');

2: writeln('февраль');

3: writeln('март');

4: writeln('апрель');

5: writeln('май');

6: writeln('июнь');

7: writeln('июль');

8: writeln('август');

9: writeln('сентябрь');

10: writeln('октябрь');

11: writeln('ноябрь');

readln;

end.

Откомпиль, если ошибки, то исправь, но вроде не должно быть

В программе а=1000

отсчитывается процент

идет цикл пока сумма не больше 1050

прибавляется процент и месяц идет дальше

Затем выбор месяца

 

Ответить

Другие вопросы из категории

Составить программу.

Определить кол-во дней между двумя днями одного и того же года (год- от 1900 до 2100).
Входные данные: файл input.txt, содержащий две строки по три числа, записанные через пробелы (дд мм гггг). Даты могут быть записаны не обязательно в порядке возрастания.
Входные данные: файл output.txt, содержащий одно число- кол-во дней между датами.

Срочно, ребят, мне сдавать уже надо!!!!

Что в векторных редакторах позволяет изменять видимость объектов, образующих рисунок?

Как устоновить пароль на архив

Читайте также

Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: а)

прирост суммы вклада за первый, второй, ..., десятый месяц; б) сумму вклада через три, четыре, ..., двенадцать месяцев.

Гражданин в первый день месяца открыл счет в банке,вложив,например,1000 долларов(S).Через каждый месяц(m) размер вклада увеличивался на 10% от всей

имеющейся суммы . Составить программу,которая определяет сумму вклада через n месяцев

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Для ремонта школы использовали белую, синюю и коричневую краски. Израсходовали одинаковое количество банок белой и синей краски. Сообщение о том, что

закончилась банка белой краски, несет 2 бита информации. Синей краски израсходовали 8 банок. Сколько банок коричневой краски израсходовали на ремонт школы?



Вы находитесь на странице вопроса "Клиент открыл счёт в банке 1 марта,вложив 1000 рублей.Каждый месяц размер вклада увеличивается на 2 процента.Определить за какой месяц величина", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.