Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить

5-9 класс

программу, которая подсчитывает общее количество целых пятизначных чисел, составленных
из различных цифр, которые обладают тем свойством, что число, образованное
первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число,
образованное последними двумя цифрами.

Например, число: 12896: 12*8=96, значит число подходит.

Ministreliya2014 23 марта 2017 г., 1:47:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mazzeko62
23 марта 2017 г., 4:40:09 (7 лет назад)

var
  i, n, a, b, c: longint;

begin
  n := 0;
  for i := 10000 to 99999 do
  begin
    a := i div 1000;
    b := (i div 100) mod 10;
    c := i mod 100;
    if a * b = c then n := n + 1
  end;
  Writeln('Найдено чисел: ', n)
end.

Результат работы программы:

Найдено чисел: 286


Ответить

Другие вопросы из категории

решите срочно

дан массив B15 поменять элементы на противоположные по знаку и вывести массив на экран

Известно. что где то правее Робота есть стена.

Составьте алгоритм. под управлением которого Робот закрасит ряд клеток до стены и вернётся в исходное положение.

Читайте также

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

1)составить программу, которая подсчитает объем любого шара по формуле: V=4/3Пr^3 2)даны действительные числа x и y. необходимо определить

принадлежит ли точка с координатами (x,y) окружности с радиусом R и центром в точке (x1,y1).

3)дан одномерный числовой массиф В(16). Необходимо вывести на экран индексы элементов значения, которых равны числу P.

cрочно надо на языке паскаль составить плиз)



Вы находитесь на странице вопроса "Составить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.