Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Очень нужно =((

5-9 класс

Ребят, как сделать, чтобы..
Например чисел 10
Каждое второе (по порядку) выводить (да)
Каждое четвёртое (по порядку) выводить (нет)

(язык паскаль)

Tktyeirf 08 дек. 2013 г., 18:21:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vennomes
08 дек. 2013 г., 19:10:59 (10 лет назад)

var
  a:array[1..100] of integer;
  i, n:integer;
begin
  randomize;
  write('Введите количество элементов '); readln(n);
  writeln('Исходный массив: ');
  for i := 1 to n do
  begin
    a[i] := random(21) - 10;
    write(a[i], ' ');
  end;
 
  writeln;
  writeln('Вывод массива в соответствии с условием: ');
  for i := 1 to n do
  begin
    if i mod 4 = 0 then
       write('нет ')
    else
      if i mod 2 = 0 then
        write('да ')
      else
        write(a[i], ' ');
  end;
end.

+ 0 -
Coolman1
08 дек. 2013 г., 20:01:58 (10 лет назад)

var
a:array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
read (a[i]);
for i:=1 to 10 do
if i mod 4 =0
then write ('нет',' ')
else
if i mod 2=0
then write ('да', ' ')
else write (a[i],' ');
end.

 

вот вставьте, если не работет напишите

Ответить

Другие вопросы из категории

Ответьте на вопросы:

1) Принципы обработки информации компьютером.
2) Компьютер и здоровье.

Найти любые алгебраические выржаения и первести их с математического языка на язык программирования.

Прошу помогите!!!! Очень надо.
ВОТ ЗАПИСИ В ТЕТРАДИ.


1)Составить алгоритм для решения задачи: Вычислить угол между двумя векторами, если эти векторы заданы своими координатами.2)Составить

алгоритм для решения задачи: Найти действительные корни квадратного уравнения вида ax^2+bx+c=0.

1 Автомат получает на вход трехзначное десятичное число. По полученном числу стрится новое десятичное числу по следующим правилам. 1 вычисляются два числа-

сумма старшего и с среднего разрядов а также сумма среднего и младшего разрядов заданного числа. 2 полученые два числа записываются друг задругом в порядке невозростания(без разделителей). Пример. Исходное число:277. Подразрядные суммы:9, 14. Результат:149. определите сколько из приведенных ниже чисел могут получиться в результате работы автомата 1616 169 163 1916 1619 316 916 116 В ответе запишите только количество чисел

Читайте также

помогите плиз очень нужно:превратите одно слово в другое всякий раз заменяя по одной букве так,чтобы новое слово было существительным в именительном падеже

.
а)ночь-?-?-?-?-?-день
б)рота-?-?-?-?-?-полк
в)бант-?-?-?-?-?-коса
г)бег-?-?-?-?-?-?-?-шаг
д)море-?-?-?-?-?-?-суша
е)миг-?-?-?-?-?-?-?-век
помогите очень нужно,учительница ужасно строгая ненавидит меня помогите!

Пожалуйста помогите!! очень срочно, нужно написать программу скорей всего мне кажется в паскале

1. Writel(' вести стоимость перчатки наприм')
read (x)
2 стоимость сумки- наприм.
3.стоимость ремня- наприм.
4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки
5.если сумма меньше 800р, то вывести сумму
Помогите пожалуйста очень нужно, благодарю!!!

Ребят,помогите пожалуйста,щедро вознагражу баллами.Очень нужна ваша помощь,нужно сделать сегодня.Таблица перелетов из Москвы в разные города.

Вопросы: 1. В какое количество городов можно долететь менее чем за 4 часа? Ответ записать в ячейку H2 таблицы. 2. Какой процент от всех 5-часовых перелетов составляют 5-часовые перелеты в Египет? Ответ на этот вопрос нужно записать в ячейку H3 таблицы с точностью одного знака после запятой

Помогите!Очень нужно)))

В строке символов определить кол-во букв А.
Нужно составить программу на Паскале))

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов



Вы находитесь на странице вопроса "Очень нужно =((", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.