Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составьте не менее трех вариантов програмы определния наименьшего из трех данных чисел

5-9 класс

Vorozhbit84 22 февр. 2015 г., 18:49:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Abishot
22 февр. 2015 г., 21:20:41 (9 лет назад)

1)

program m;
uses crt;
var i,a,b,c,min:integer;
begin
clrscr;
readln(a,b,c);

if a<min then min:=a;
if b<min then min:=b;
if c<min then min:=c;
writeln('        ',min);
readkey;
end.

 

2)

program m;
uses crt;
var i,a,b,c,min,d:integer;
begin
clrscr;
readln(a);
min:=a;
for i:=1 to 2 do            

                                    begin
readln(a);
if a<min then min:=a;
                                    end;
writeln(min);

readkey;

end.

 

3)

program m;
uses crt;
var i,a,b,c,min,d:integer;
begin
clrscr;
readln(a,b,c);
if a<b then b:=a;
if c<a then b:=c;
writeln(b);
readkey;
end.

Ответить

Другие вопросы из категории

По горизонтали:

1. Одно из основных устройств, входящих в состав компьютера

5. Описание устройства и принципов работы компьютера

6. Поименованная совокупность однотипных данных

7. Один из типов памяти компьютера

8. Она содержит команды ля процессора, который решает задачу, последовательно
их выполняя.

сколько байтов в слове бит

Читайте также

Решить в Паскале (без массива) №1 Составьте не менее трёх вариантов программы определения наименьшего их трех данных чисел. №2 Составить программу

сортировки по возрастанию значений трёх переменных : А,В,С . №3 Заданы Размеры а,в прямоугольного отверстия x,y,z кирпича. Определить пройдет ли кирпич через отверстие .

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

ПОМОГИТЕ ПОЖАЛУЙСТА!

На языке паскаль составить программу , выводящую на экран наименьшее из трех чисел.Программа должна выводить на экран результат в виде:Наименьшее из данных трех чисел=Значение.

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для

созданной программы не менее трех тестов и проверить на них правильность работы алгоритма.
БЕЗ МАССИВА
ПОЖАЛУЙСТА
+194884839383948 К КАРМЕ ТОМУ КТОНАПИШЕТ

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите

номер дня, на который пробег спортсмена составит не менее y километров. Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.



Вы находитесь на странице вопроса "составьте не менее трех вариантов програмы определния наименьшего из трех данных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.