Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите срочнооо) pascal abc 1. Развернуть обе половинки массива в обратном порядке. Считая, что массив имеет четное число элементов.

10-11 класс

Пояснения

Из массива (1, 2, 3, 4, 5, 6, 7, 8) нужно получить массив (4, 3, 2, 1, 8, 7, 6, 5).

2. Сдвинуть все элементы массива на одну позицию влево (циклически). Первый элемент должен оказаться на месте последнего.
3. Сдвинуть все элементы массива на одну позицию вправо (циклически). Последний элемент должен оказаться на месте первого.

Darinamilana 28 июля 2013 г., 2:08:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Verynika2209
28 июля 2013 г., 4:08:03 (10 лет назад)

Во всех программах у меня будет использоваться процедура swap:

 

procedure swap(a: ^real; b: ^real);
var
   t: real;
begin
   t := a^;
   a^ := b^;
   b^ := t;
end;

 

swap(x,y) - меняет местами значения x и y.

 

1.

var
   A: array[1..100] of real;
   i, j, N: integer;

begin

   readln(N);
   for i := 1 to N do
      read(A[i]);
   for j := 1 to (N div 2) - 1 do
      for i := 1 to (N div 2) - j do
         swap(A[i], A[i + 1]);
   for j := 1 to (N div 2) - 1 do
      for i := (N div 2) + 1 to N - j do
         swap(A[i], A[i + 1]);
   for i := 1 to N do
      writeln(A[i])
end.

 

2.

var
   A: array[1..100] of real;
   i, N: integer;

begin

   readln(N);
   for i := 1 to N do
      read(A[i]);
   for i := 1 to N - 1 do
      swap(A[i], A[i + 1]);
   for i := 1 to N do
      writeln(A[i])
end.

 

3.

var

   A: array[1..100] of real;
   i, N: integer;

begin

   readln(N);
   for i := 1 to N do
      read(A[i]);
   for i := N downto 2 do
      swap(A[i], A[i - 1]);
   for i := 1 to N do
      writeln(A[i])
end.

Ответить

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.



Вы находитесь на странице вопроса "помогите срочнооо) pascal abc 1. Развернуть обе половинки массива в обратном порядке. Считая, что массив имеет четное число элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.