Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может взять себе не

5-9 класс

больше половины огорода (размеры участков после раздела должны быть целыми и участки прямоугольными). Вывести '1' - если участок деда оказался меньше, '0' - если участки равны.
Входные данные:
Во входном потоке в первой строке заданы целые числа A, B (A, B < 1000).

Выходные данные:
Вывести единственное целое число.

Пример входного файла (input.txt):
8 4

Romka9514 20 сент. 2014 г., 20:32:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tamaradenisova12
20 сент. 2014 г., 21:04:28 (9 лет назад)

var
  a, b: integer;
begin
  assign(input, 'input.txt');
  assign(output, 'input.txt');
  reset(input);
  rewrite(output);
  readln(input, a, b);
  if (a mod 2 = 1) then
    writeln(output, b mod 2)
  else
    writeln(output, '0');
  close(input);
  close(output);
end.

Ответить

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

№ 1 Моя семья. мне уже 31год, моему брату на 13 лет больше. младшая сестра на 3 года моложе меня: ей 22 года. моему отцу столько лет, сколько в сумме мне,

брату и сестре. возраст мамы получается, есливычесть половину возраста сестры из возраста отца. сколько лет каждому? чем объяснить странные противоречия в числах? восстановите текст, устранив противоречия.
№2 толя сережа купили конфеты. они решили поделить их поровну, но оказалось . что конфет 27, тогда они разделили на две кучки по 13 и 14 конфет и решили сыграть в игру: кто"будут по очереди брать . кто последний возмет, тот и выиграл. за один ход можно брать любое количество, но только из одной кучки. выигравший заберает конфеты. кто должен ходить первым, чтобы Сережа выиграл, и какую стратегию ему применить?
№3 три ученика разных школ. на вопрос , в каких школах они учатся, каждый дал ответ. Павел:"учусь в школе 24, а Лиля в 8школе"
Лиля: " учюсь в школе 24, а павел в 30 школе"
Ярик: " учусь в школе 24, а Павел в 8 школе"
где правда , а где лож? Ребята сознались, что в ответах каждого из них одно утверждение верно, а другое ложно.

Нарисовать квадрат со сторонами 20*20, так чтобы границы верхние и нижние(-------) были красного цвета, боковые (|||||||||||||)

были красного цвета, а в середине квадрата (////////) были линии жёлтого цвета. Задача в Паскале.Заранее спасибо.Очень срочно.

Боря,Витя,гриша и Егор встретились на всероссийской олимпиаде по информатике. Ребята приехали из разных городов: москвы , Омска, Санкт-Петербурга и

Кирова. Известно что Боря жил в одной комнате с мальчиком из Кирова и ни один из этих двух мальчиков никогда не был ни в Москве, ни в санкт-петербурке. Гриша играл в одной комнате с мальчиком из Москвы, а вечерами к ним заходил приятель из Кирова. Егор и мальчик из Москвы увлекаются игрой в шахматы . кто из ребят откуда приехал?

Для шифрования сообщения был выбран следующий метод: сдвиг каждой из 33 букв русского алфавита на 3 буквы вперед, при этом алфавит считается циклическим, т

о есть буква "я" переходит в букву "г".
Расшифруйте слова и выберите те из них, которые обозначают устройства, входящие в состав персонального компьютера.
1)УФЕЪИХХТФ
2)МСЦИЖФДП
3)УПДЦД
4)ЗМХО
5)УФТМЁТЗСДГ
6)УТПИ



Вы находитесь на странице вопроса "Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может взять себе не", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.