Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны целые положительные числа A и B найдите их наименьшее общее кратное НОК используя алгоритм Евклида: НОК(A,B)=НОК(B,A mod B), если B не равен

5-9 класс

0; NOK(A;0)=A

Desh386 05 авг. 2014 г., 3:56:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Сончис
05 авг. 2014 г., 5:33:24 (9 лет назад)

var
    a, b, c, a1, b1:integer;
begin

    Writeln('Введите A и B:');
    Readln(a, b);

    a1 := a;
    b1 := b;

    while b1 <> 0 do
    begin
        c := a1 mod b1;
        a1 := b1;
        b1 := c;
    end;

    if b <> 0 then
        Writeln('НОК(', a,',', b,') = ', a div a1 * b)
    else
        Writeln('НОК(', a,',', b,') = ', a);


end.

 

+ 0 -
танечка2001
05 авг. 2014 г., 7:46:10 (9 лет назад)

сори в начале не понял, что нужен евклид, я исправился: 

uses crt;
function NOD(m,n:integer):integer;
begin
If m<>0 then NOD:=NOD(n mod m,m) else NOD:=n;
end;
function NOK(m,n:integer):integer;
begin
NOK:=(m div NOD (m,n))*n;
end;
var x,y: integer;
begin
clrscr;
writeln('Vvedite x y :');
readln(x,y);
writeln (NOK(x,y));
readln;
end.

Ответить

Другие вопросы из категории

помогите составить ребусы:

текстовый редактор
документ
курсор

1)Определите значение с после выполнения следующего фрагмента программы а:= 100; b:=30; а:= а-b*3; if a>b then c:= а-b

else с:= b-a;

2) Чнму равна сумма элементов а{1} и а{4} массива, сформированного следующим образом.

for i:= 1 to 5 a{i} :=i*(i+1)

Помогите, срочно!) НУЖНО СОСТАВИТЬ ПРОГРАММУ ВЫЧИСЛЕНИЯ. Для данного х вычислите у по формуле у=x^3+2,5^2-x+1. при этом а)оператор возведения в

степень использовать нельзя

б)в одном операторе присваивания не более одной арифметической операции(сложение, умножение, вычитание)

в) должно быть не более пяти операторов присваивания.

Подсказка (x+2,5)x-1)x+1

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Дано целое число N и набор из N целых чисел. Найти минимальное положительное число из данного набора. Если положительные числа в наборе отсутсвуют, то

вывести 0.
С выводом минимального положительного числа у меня вроде бы получилось, а вот с проверкой на отрицательность не вышло

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ
Одно целое положительное число, не превышающее 1000. Одно целое положительное число, не превышающее 1000. ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число. На языке С

Дано целое положительное четырехзначное число. Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует

первой цифре заданного числа, а число единиц-последней. Например: 3234 => 34.



Вы находитесь на странице вопроса "Даны целые положительные числа A и B найдите их наименьшее общее кратное НОК используя алгоритм Евклида: НОК(A,B)=НОК(B,A mod B), если B не равен", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.