Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

подскажите, составить программу вычесления: суммы всех положительных элементов массива.

5-9 класс

буду благодарна.

Valentaja 22 дек. 2013 г., 12:56:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
25Мария
22 дек. 2013 г., 14:36:16 (10 лет назад)

var

a:array[1..1000]of integer;

i,sum:integer;

begin

readln(n);

sum:=0;

for i:=1 to n do begin

read(a[i]);

inc(sum,a[i]);

end;

writeln(sum);

end.

Ответить

Другие вопросы из категории

Уточните, каков объём оперативной памяти компьютера , к которому вы имеете доступ дома или в школе. Сколько страниц текста можно разместить в памяти этого

компьютера ( на странице размещается 40 строк по 60 символов в каждой строке , а для хранения одного символа требуется 8 битов)? Какой была бы высота такой стопки страниц, если высота стопки из 100 страниц равна 1 см?

В марафоне участвуют 24 атлета. Спец. устройство регистрирует прохождение финиша.,записывая его номер с мин. кол-вом бит.каков объем информ. сообщения

если зарегистрировано 50% атлетов??? ЛАЙК НА ТВОЮ СТРАНИЦУ ЕСЛИ БУДЕТ КРАТКОЕ РЕШЕНИЕ ПОНЯТНОЕ!!!

Информатика, Pascal

Цикл с предусловием
Напишите программу, которая будет находить первую цифру числа.

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

1) Все положительные элементы массива А увеличить на 0.4, нулевые заменить на 0.5, определить сумму отрицательных элементов и произведение

положительных элементов.

2)Найти количество пар взаимообратных соседних чисел в линейной таблице Х[1:N].

3)Упорядочите элементы массива А в порядке убывания.

4)При поступлении в институт абитуриенты набирают определенное количество баллов. Считая фамилии абитуриентов и набранное ими количество баллов исходными данными, составить список будущих студентов, если известно что на выбранный факультет будет зачислено М человек.



Вы находитесь на странице вопроса "подскажите, составить программу вычесления: суммы всех положительных элементов массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.