Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дана строка.

10-11 класс

Если она представляет собой запись целого числа, то вывести 1, если
вещественного (с дробной частью) — вывести 2; если строку нельзя
преобразовать в число, то вывести 0. Считать, что дробная
часть вещественного числа отделяется от его целой части десятичной точкой «.».

Igor5555 24 дек. 2014 г., 7:36:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yasma226062004
24 дек. 2014 г., 9:18:21 (9 лет назад)

var
  s: string;
  t: integer;
  t1: real;

begin
  readln(s);
  if not (Integer.TryParse(s, t)) then
    if not (Real.TryParse(s, t1)) then
      t := 0
    else
      t := 2
  else
    t := 1;
  writeln(t);
end.

Ответить

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

дана строка символов

Сколько раз среди данных символов встречаться цифра?
паскаль. подскажите

дана строка. Каждую точку замените многоточием (т.е тремя точками). В чем беда? или совсем не правильно?

var str : string;
q:integer;
k:string;
begin
writeln ('введите строку');
readln (str);k:='..';
q:=pos('.', str );
while q<>0 do
begin
insert (str,k, q );
q:=pos('.', str );
end;
writeln (str);
end.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "Дана строка.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.