Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны натуральное число n и последовательность целых чисел а1, а2, … аn. Из наибольшего элемента извлечь квадратный корень. Составить блок-схему

10-11 класс

алгоритма, написать программу.

Vov4ik199696 07 дек. 2014 г., 7:33:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jsotnickova
07 дек. 2014 г., 10:03:56 (9 лет назад)

program xxx;
  var i, n, max : integer;
        s : real;
        a : array [1..20] of integer;
begin
  write ('введите n= ');
  readln(n);
  for i:=1 to n do
     readln (a[i]);
  max:= a[1];
  for i:=1 to n do
      if a[i] > max then max := a[i];
  s:= sqrt(max);
  write ('корень из наибольшего эл-та =', s)
end.

Ответить

Другие вопросы из категории

Вычислить значение функции:
Задача: Напишите функцию revpositn, которая получает два параметра str1 и str2 типа string и возвращает позицию начала первого появления str1 текста,

содержащего литеры str2 в обратном порядке. Например revpositn('внешность','сон') должно возвратить 5, потому что строка 'нос' (перевернутое сон) содержится в слове 'внешность' начиная с 5-й позиции. Заметим также, что revpositn('внешность', 'нос') дает 0.(пожалуйста обьясните подробно как делать задачу)

Читайте также

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn..Все

положительные элементы уменьшить в 2 раза. Составить блок-схему алгоритма, написать программу

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Даны натуральное число n и последовательность целых чисел а1, а2, … аn. Из наибольшего элемента извлечь квадратный корень. Составить блок-схему", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.