Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn. Найти количество и сумму тех членов последовательности, которые делятся на 5 и

10-11 класс

не делятся на 3. Составить блок-схему алгоритма, написать программу

Budaev443 27 авг. 2014 г., 6:58:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lidazinoveva8
27 авг. 2014 г., 7:32:01 (9 лет назад)

Пожалуйста:

Program 123;
Uses crt;
Var i,s:integer;
Begin
Clrscr;
s:=0;
For i:=1 to 50 do
if (i mod 5=0) and (i mod 3<>0) then
Begin
s:=s+i;
Write(i,' ');
End;
WriteLn('Сумма: ',s);
ReadLn;;
End. Блок-схему легко и самому по записи сделать.

Ответить

Другие вопросы из категории

Выполнить в paskal

N=12 Ввести число К Определить количество элементов массива, значения которых больше K.
...
Все элементы массива увеличить в 3 раза. Массив вывести.
...
Определить максимальное значение сред положительных элементов массива.

Помоите решить.Циклы(паскаль).В послед a1,a2,a3,...an каждый член, начиная с четвёртого, равен последней цифре суммы трёх предыдущих. Найти n-ый

элемент последовательности.Да хотелось бы еще чтобы каждая строчка была расписана что в ней происходит.

Математическая модель объекта - это описание объекта-оригинала в виде:

a. Рисунка
b. Схемы
c. Графика функции
d. Текста

Помогите очень надо!!

Составить программу,которая определяет возраст человека по количеству дней, с учётом год, года,лет. в раскале!

Читайте также

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Даны натуральное число n и последовательность целых чисел а1, а2,…,аn. Найти количество и сумму тех членов последовательности, которые делятся на 5 и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.