Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помоите решить.Циклы(паскаль).В послед a1,a2,a3,...an каждый член, начиная с четвёртого, равен последней цифре суммы трёх предыдущих. Найти n-ый

10-11 класс

элемент последовательности.Да хотелось бы еще чтобы каждая строчка была расписана что в ней происходит.

Катя2502 31 июля 2014 г., 2:27:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bactiyor
31 июля 2014 г., 4:23:33 (9 лет назад)

uses crt; {Подключение внешнего модуля}

var {Описание переменных}
a:array [1..100] of integer; 
n,i:integer;
begin
write('n='); {Вывод текста на экран}

read(n); {Чтение текста}
for i:=1 to 3 do
a[i]:=random(51); {Значение первых 3 элементов}
for i:=4 to n do
a[i]:=((a[i-1]+a[i-2]+a[i-3]) mod 10); {Значение остальных элементов}
writeln('Последовательность:'); {Вывод текста на экран}
for i:=1 to n do
write(a[i],' '); {Вывод последовательности на экран}
writeln; {Перевод указателя на следующую строку}
write('N-ный элемент: ',a[i]); {Вывод текста и элемента на экран}
end.

Ответить

Другие вопросы из категории

Математическая модель объекта - это описание объекта-оригинала в виде:

a. Рисунка
b. Схемы
c. Графика функции
d. Текста

Помогите очень надо!!

Составить программу,которая определяет возраст человека по количеству дней, с учётом год, года,лет. в раскале!

TURBO Pascal

var
i,N:integer;
begin
writeln('Vvedite N');
readln(N);
for i:=1 to n do
if (i mod 2<>0)and(i mod 3<>0)and(i mod 5<>0)then writeln(i);
readln
end.

Данная программа выдает все числа, от 1 до заданного (n), которые не делятся без остатка на 2,3,5. что нужно исправить, чтобы программа выдавала только количество этих чисел.
Заранее спасибо.

Читайте также

Дано n, . Вычислить: a1 - a2 + a3- …+ (-1)n+1 an. Дано n, . Получить последовательность , где b1

= a1, b2 = a1+ a2, …, bn = a1+ an. Дано n. Получить последовательность , где Даны n,. Получить сумму и количество тех элементов данной последовательности, которые кратны 5 и не кратны 4. Даны n,. Вычислить Даны n и . Получить a1, a2, …, an , 2a1, 3a2, …, (n + 1)n an. Выяснить образуют ли они возрастающую последовательность.

решить в паскале

Даны действительные числа a1,......, a24. Получить последовательность b1,........, b10, где b1=a1+a2+.....+a24, b2= a1^2+a2^2+.......+a24^2,........ b10=a1^10+a2^10+.......+a24^10.

Помогите решить!!!

В массиве a1,a2,a3,,,a10 найти максимальный элемент и его порядковый номер и поменять его местами с последним элементом массива

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

Помогите решить)

Ввести массив a1,a2,a3..a20.Элементы, на чётных местах, расположить в порядке возрастания , а на нечётных в порядке убывания. У этого сайта нет рейтинга



Вы находитесь на странице вопроса "Помоите решить.Циклы(паскаль).В послед a1,a2,a3,...an каждый член, начиная с четвёртого, равен последней цифре суммы трёх предыдущих. Найти n-ый", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.