Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

треугольник задан величинами своих углов и радиусом описанной окружности.Вычеслить длины сторон треугольника.

10-11 класс

Sashashan 27 апр. 2014 г., 1:32:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
котік123
27 апр. 2014 г., 3:28:40 (10 лет назад)

var
  a, b: array [1..3] of real;
  r: real;

begin
  writeln('Введите углы (A, B, C), затем - радиус');
  readln(a[1], a[2], a[3], r);
  b[1] := r * 2 * sin(a[1]);
  b[2] := r * 2 * sin(a[2]);
  b[3] := r * 2 * sin(a[3]);
  writeln('a = ', b[1]);
  writeln('b = ', b[2]);
  writeln('c = ', b[3]);
end.

+ 0 -
Nata8408
27 апр. 2014 г., 4:00:37 (10 лет назад)

паскаль

Ответить

Другие вопросы из категории

помогите бестрей плиз 8 класс!!
Написать программу на паскале по такому вот вопросу:

"Вводиться 3 числа. Есть ли вероятность того, что одно из них оканчивается на 0?"

1.Сколько секунд потребуется обычному модему,

передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640Х480
пикселей при условии, что цвет каждого
пикселя кодируется тремя битами?

Скорость передачи данных через ADSL‑соединение равна 32000 байт/c.

Определите размер файла, который будет передан через 1 минуту. Ответ выразите в Кбайтах.

Читайте также

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.

Pascal.Помогите решать хотя бы некоторые!!!Очень нужно.

Задача 1. Ввести три вещественных числа: длины сторон треугольника. а) Напечатать существует ли треугольник с такими длинами сторон; б) Если треугольник существует, то напечатать тип треугольника: остроугольный,
прямоугольный или тупоугольный.
Задача 2. Компьютер в первую секунду печатает на экране 1, во вторую – число 12, в третью – число 23. То есть, в каждую следующую секунду – на 11 больше, чем в предыдущую. В
какую секунду впервые появится число, делящееся на 2009?
Задача 3. Текст состоит из слов, разделенных пробелом. Найти самое длинное слово. Если таких слов несколько, то напечатать последнее. Задача 4. Ввести натуральное число N. Это число записывается в виде суммы нескольких неубывающих натуральных слагаемых. Например, 5=1+4=2+3=1+1+3=1+1+1+2=1+1+1+1+1
Напечатать количество таких изложений (при n=5, ответ 5);



Вы находитесь на странице вопроса "треугольник задан величинами своих углов и радиусом описанной окружности.Вычеслить длины сторон треугольника.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.