Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано n, . Вычислить: a1 - a2 + a3- …+ (-1)n+1 an. Дано n, . Получить последовательность , где b1

10-11 класс

= a1, b2 = a1+ a2, …, bn = a1+ an. Дано n. Получить последовательность , где Даны n,. Получить сумму и количество тех элементов данной последовательности, которые кратны 5 и не кратны 4. Даны n,. Вычислить Даны n и . Получить a1, a2, …, an , 2a1, 3a2, …, (n + 1)n an. Выяснить образуют ли они возрастающую последовательность.

Мерей 14 июня 2013 г., 9:41:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kep32112
14 июня 2013 г., 12:14:37 (10 лет назад)


Program Alenka1;
const n=20;
var
 a:array[1..n] of integer;
 i,sum: integer;
begin
  sum:=0;
  for i:=1 to n do
    begin
      write('Введите ',i,'-e число ');
      readln(a[i]);
      if (i mod 2)=1 then sum:=sum+a[i]
        else sum:=sum+a[i];
    end;
  writeln('Сумма равна ',sum);
end.

Program Alenka2;
const n=20;
var
 a,b:array[1..n] of integer;
 i: integer;
begin
  write('Введите 1-e число ');
  readln(a[1]);
  b[1]:= a[1];
  for i:=2 to n do
    begin
      write('Введите ',i,'-e число ');
      readln(a[i]);
      b[i]:= b[i-1]+a[i];
    end;
  for i:=1 to n do
    begin
      writeln('A[',i,']= ',a[i],'  B[',i,']=',b[i]);
    end;
end.

Program Alenka3;
const n=20;
var
 a:array[1..n] of integer;
 i,k,sum: integer;
begin
  sum:=0;
  k:=0;
  for i:=1 to n do
    begin
      write('Введите ',i,'-e число ');
      readln(a[i]);
      if (a[i] mod 5 = 0) AND (a[i] mod 4 <> 0) then
      begin
        sum:=sum+a[i];
        k:=k+1;
      end;
    end;
  writeln('Сумма таких элементов = ',sum);
  writeln('Их количество = ',k);
end.

Program Alenka4;
const n=20;
var
 a,b:array[1..n] of real;
yes: boolean;
i: integer;
begin
  yes := TRUE;
  write('Введите 1-e число ');
  readln(a[1]);
  b[1]:= a[1]*2;
  for i:=2 to n do
    begin
      write('Введите ',i,'-e число ');
      readln(a[i]);
      b[i]:= (i+1)*power(a[i],i);
      if (b[i]<b[i-1]) then  yes := FALSE;
    end;
  for i:=1 to n do write(b[i],'  ');
  writeln;
  if yes then writeln('эти числа образуют возрастающую последовательность')
    else writeln('эти числа НЕ образуют возрастающей последовательности');
end.

Ответить

Другие вопросы из категории

Помогите сделать 1 номер
Определить, кто из четырех студентов сдал экзамен,

если известно:
1) Если первый сдал, то и второй сдал;
2) Если второй сдал, то третий сдал или первый не сдал;
3) Если четвертый не сдал, то первый сдал, а третий не сдал;
4) Если четвертый сдал, то и первый сдал.

Pascal

Найти сумму всех двухзначных чисел, которые кратны трём.

Как сделать так чтобы выводилось число которое ввёл пользователь

вот программа:

язык программирования: паскаль

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1)Составить алгоритм нахождения количества положительных элементов с последовательностью целых чисел b1, b2, b3, ..., bn 2)Составить алгоритм и

блок-схему нахождения произведения отрицательных чисел с последовательностью a1, a2, a3, ..., an

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

Срочно!!!Помогите пожалуйста! Всем известно, что «от перестановки слагаемых сумма не изменяется». Однако, случается и так, что перестановка двух чисел

приводит к более интересным последствиям.

Пусть, например, заданы три числа: a1, a2, a3. Рассмотрим равенство a1+ a2= a3. Оно может быть неверным (например, если a1= 1, a2= 4, a3= 3), однако может стать верным, если поменять некоторые числа местами (например, если поменять местами a2 и a3, оно обратится в равенство 1 + 3 = 4).

Ваша задача – по заданным трем числам определить: можно ли их переставить так, чтобы сумма первых двух равнялась третьему.

Входные данные

Входной файл INPUT.TXT содержит три целых числа: a1, a2, a3 (−108 ≤ a1, a2, a3 ≤ 108).

Выходные данные

В выходной файл OUTPUT.TXT выведите слово «YES», если заданные числа можно переставить так, чтобы сумма первых двух равнялась третьему. В противном случае выведите в выходной файл слово «NO».

Помоите решить.Циклы(паскаль).В послед a1,a2,a3,...an каждый член, начиная с четвёртого, равен последней цифре суммы трёх предыдущих. Найти n-ый

элемент последовательности.Да хотелось бы еще чтобы каждая строчка была расписана что в ней происходит.



Вы находитесь на странице вопроса "Дано n, . Вычислить: a1 - a2 + a3- …+ (-1)n+1 an. Дано n, . Получить последовательность , где b1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.