Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Пожаааалуйста, помогите(только не из интернета брать, там не правильно).

10-11 класс

Даны две точки А(х1,у1) и В(х2,у2). Составить алгоритм, определяющий, которая из точек находится ближе к точке (2,5).(Паскаль).

Алина02072003 17 сент. 2013 г., 15:14:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alex512575
17 сент. 2013 г., 16:04:38 (10 лет назад)

const

  y = 5;

  x = 2;

var

  x1,x2,y1,y2:integer;

begin

  write('x1 = ');  readln(x1);

  write('y1 = ');  readln(y1);

  write('x2 = ');  readln(x2);

  write('y2 = ');  readln(y2);

 

  if sqrt(  (x1-x) * (x1-x)  + (y1 - y) * (y1 - y))   <   sqrt(  (x2-x) * (x2-x)  + (y2 - y) * (y2 - y)) then

    writeln('A ближе')

  else

     if sqrt(  (x1-x) * (x1-x)  + (y1 - y) * (y1 - y))   >   sqrt(  (x2-x) * (x2-x)  + (y2 - y) * (y2 - y)) then

       writeln('B ближе')

     else

       writeln('Они на одинковом расстоянии');

readln;

end.

   

Ответить

Другие вопросы из категории

Дан двумерный массив целых числе i=10 j=15, Заполняется случайным образом целыми числами от 0до 100. 1) Определить сколько раз в нем встречается

элемент со значеием х. х задается прользователем

2) Определить количесво четных элементов массива.

Составить 5 примеров на mod и div
переведите из 10-ой системы в 8-ную 1142 (10)-(8)

327 так же

Читайте также

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

1. Расширение файла, как правило, характеризует:

тип файла

программное обеспечение

название программы

2. Файл - это:

поименованный объект, расположенный на диске

поименованная совокупность байтов, размещенная на внешнем носителе

совокупность поименованных ячеек памяти

3. Задан полный адрес файла: c:\documets\prikaz.doc. Какое у файла составное имя?

prikaz.doc

documets\prikaz.doc

documets\prikaz

^ 4. К сервисным системам относятся:

интерфейсные системы

инструментальные системы

утилиты

программные системы

оболочки

^ 5. Какое программное обеспечение обеспечивает рабочую среду для других программ:

прикладное

системное

инструментальное

^ 6. Какая версия программного продукта является более новой:

MS DOS 6.0

MS DOS 6.20

MS DOS 6.22

7. Программы, скачанные из Интернета и имеющие определенный срок пользования, являются:

платными

бесплатными

условно-бесплатными

^ 8. Интерфейс, в котором для управления компьютером используются объекты, называется:

объектно-ориентированным

графическим

командным

^ 9. Программы, которые существенно меняют пользовательский интерфейс, не меняя при этом программный, относятся к:

утилитам

интерфейсным системам

оболочкам

^ 10. Какой шаблон позволяет найти файлы, которые начинаются на букву f, заканчиваются на t и имеют любое расширение:

*f????t.*

f*?d.*??

f?*d.*

^ 11. Сколько различных операционных систем можно установить на одном жестком диске:

только одну

только две

только три

12. Какое максимальное число логических дисков можно создать в расширенном разделе:

три

любое

23

13. После форматирования диска его доступный объем может уменьшиться по причине:

наличия на диске логических ошибок

наличия испорченных секторов

наличия фатальных ошибок

Информатики, помогите! Не работает интернет, и вот такой крестик.

что это значит, и почему он не работает?
как мне это исправить?

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)



Вы находитесь на странице вопроса "Пожаааалуйста, помогите(только не из интернета брать, там не правильно).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.