Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Лазарус:

10-11 класс

1.

Clima 17 нояб. 2013 г., 23:48:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maiko7891
18 нояб. 2013 г., 1:43:35 (10 лет назад)

uses crt;
var a, b, c, i, j, n:integer;   
s, k :array [1..10000] of integer;
begin
     clrscr;
     writeln ('Введите размер массива > 4.');
     read (n);
     for i:=1 to n do 
     begin 
          writeln ('Введите ', i, ' элемент.'); 
          read (s[i]); 
     end;
     for i:=1 to n do 
          for j:=1 to n-1 do 
               while s[i]=s[j] do   
               begin   
                    j:=j+1;   
                    inc (k[i]);   
               end;
     a:=k[1];
     for i:=1 to n do 
          if a<k[i] then
               a:=k[i];
     if k[i]=0 then k[i]:=1;
     writeln ('Наибольшая длина равных элементов идущих последовательно равна ', k[i], '.');
     for i:=1 to n-5 do 
          if (s[i+4]-s[i+3]=1) and (s[i+3]-s[i+2]=1) and (s[i+2]-s[i+1]=1) and (s[i+1]-s[i]=1) then  inc (b);
     if b=0 then writeln ('Нет 5 последовательны чисел.') else writeln ('Есть 5 последовательных чисел и это количество равно ', b);
end.

P.S. Надеюсь на благодарность и лучший ответ.

Ответить

Другие вопросы из категории

Сколько существует различных символьных последовательностей длины 5 в

четырехбуквенном алфавите {A, C, G, T}, которые содержат ровно две буквы
A?

сформировать отдельный модуль,содержащий описание трех подпрограмм, реализирующих умножение матриц размерности 3*3,умножение матрицы на вектор и

умножение двух векторов. подключить этот модуль к программе,найти произведения A*B,A*C,C*D (А и В - матрицы 3х3,С и D -вектора)

Задача 1.

Составьте программу, которая выводит на экран таблицу
перевода a, a+1,
a+2, … b бит в килобайты. Границы
a и b вводятся с клавиатуры.

1.

Читайте также

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20].

Найти номер первого отрицательного элемента, делящегося на 5 с остатком 2.напишите пожалуйста программу в лазарусе



Вы находитесь на странице вопроса "Лазарус:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.