Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать алгоритм следующей задачи: подсчитать сколько в массиве значений, равных 5 и вывести на экран.(задача по проге С++)Пожайлуста скорее, если

10-11 класс

можно

Bluma04 16 нояб. 2013 г., 13:59:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wyvu
16 нояб. 2013 г., 16:11:12 (10 лет назад)

#include <iostream>

#include <windows.h>

 

using namespace std;

 

int main()

{

   int N;

   int* arr;

   cin>>N; //вводим размер массива

   arr = new int[N];

   for(int i=0;i<N;i++)  cin>>arr[i]; //вводим сам массив

   int NumOfFives = 0;

   for(int i=0;i<N;i++)

   {

     if(arr[i]==5) NumOfFives++;

   }

   cout<<NumOfFives<<endl; //выводим сколько пятёрок

   Sleep(5000); //ждём 5 секунд.

   delete arr;

   return 0;

}

 

/*

  P.S Так на будующее:  не алгоритм, а программу; C++ не программа, а язык; за такие задачи нужно побольше пунктов давать(мало кто знает C++(тут), а также задачи тут бывают полехче (куда уж легче? но бывают!) а пунктов ты даёшь минимум).

 

*/

Ответить

Другие вопросы из категории

Сколько существует различных символьных последовательностей длины 5 в

четырехбуквенном алфавите {A, C, G, T}, которые содержат ровно две буквы
A?

сформировать отдельный модуль,содержащий описание трех подпрограмм, реализирующих умножение матриц размерности 3*3,умножение матрицы на вектор и

умножение двух векторов. подключить этот модуль к программе,найти произведения A*B,A*C,C*D (А и В - матрицы 3х3,С и D -вектора)

Задача 1.

Составьте программу, которая выводит на экран таблицу
перевода a, a+1,
a+2, … b бит в килобайты. Границы
a и b вводятся с клавиатуры.

1.
Файл содержал несжатую

стереофоническую музыкальную композицию, оцифрованную с частотой дискретизации
22000 Гц и 65536 уровнями квантования. После преобразования файла за счет
уменьшения количества уровней квантования до 4096 при сохранении частоты
дискретизации, его объем уменьшился на 4125 Кбайт. Какова была
продолжительность записанной музыкальной композиции?

Читайте также

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

Дан массив Array[1..100]

С помощью цикла присвоить, каждому элементу массива значение равное номер элемента умноженный на 3. например для массива А значение элемента А[1]=2, A[2]=6 A[3]=9 и т.д. В конце программа должна выводить на экран сумму всех элементов массива.



Вы находитесь на странице вопроса "Написать алгоритм следующей задачи: подсчитать сколько в массиве значений, равных 5 и вывести на экран.(задача по проге С++)Пожайлуста скорее, если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.