Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дано число а. возвести его в n-ую степень. задача на тему "цикл с известным числом повторения!" помогите пожалуйста

5-9 класс

MrsHolms 26 марта 2015 г., 20:35:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marinanirsha8
26 марта 2015 г., 22:27:05 (9 лет назад)

program name;

var integer:a,i,b;

begin

b:=1

read(a,i);

for i:=1 to i do

b:=b*a;

write(b);

end.

вот и все в принципе.a -это число возведенное в степень i.

b-число например 2 в сепени 3=8(тут b=8,a=2,i=3)

 

+ 0 -
Knollen39
27 марта 2015 г., 0:49:05 (9 лет назад)

Я бы написал по другому

 

Program vozvedenie_v_stepen;

var a,b:integer;

begin

writeln ('Введите число, которое будем возводить в степень');

readln (a);

writeln ('Введите число, обозначающее степень, в которую будем возводить');

readln (b);

Writeln (a,' в степени ',b,' = ',exp(b*ln(a))); 

end. 

 

Извиняюсь за неправильный ответ. Не увидел, что вам нужно с циклом. Тогда лучше так...

 

Program vozvedenie_v_stepen;
var a,b,c,d:integer;
begin
writeln ( 'Введите число, которое будем возводить в степень' );
readln (a);
c:=a;
writeln ( 'Введите число, обозначающее степень, в которую будем возводить');
readln (b);
for d:= 2 to b do
a:=a*c;
if b=0 then
writeln(1)
else
writeln (c,' в степени ',b,' = ',a);
end. 

Ответить

Другие вопросы из категории

Читайте также

1.Напишите программу расчёта площади прямоугольника,если известны его периметр и длина одной из сторон. Входные данные вводятся пользователем с экрана.

Вывод так же осуществляеться на экран.
2.Дана последовательность чисел а,b,c. Все отрицательные числа заменить на нули. Входные данные вводятся пользователем с экрана. Вывод так же осуществляется на экран.
Нужно составить вроде таблицу алгоритмов,помогите пожалуйста.
Я не прошу схемотично,хотя бы описание,где что должно быть написано,очень надо,помогите



Вы находитесь на странице вопроса "дано число а. возвести его в n-ую степень. задача на тему "цикл с известным числом повторения!" помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.